SMS: License Metering Client Tries to Log On to Server Multiple Times (287626)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
- Microsoft Systems Management Server 2.0 SP2
- Microsoft Systems Management Server 2.0 SP3
This article was previously published under Q287626 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When a client account is locked out, multiple logon failures in the Microsoft Windows NT Security Event log are registered on license metering servers.
CAUSE
The license metering client uses the currently logged on user account to
authenticate and connect to the license metering server to copy log files. If that user's account is disabled, locked out, or otherwise invalid, the license metering client attempts hundreds of logon attempts on the license metering server, and this creates very large security log files.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUNDWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
The retry algorithm can be changed (through the addition of two registry keys) to specify the number of retries and the time limit between retries. You would need to make this setting on each of the client computers, and you could do so by using an SMS Installer script. To manually add these registry keys, use the following steps on each client:
- Use Registry Editor (Regedt32.exe) to locate the following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Client\Client Components\License Metering\Properties - Add the number of times to retry a logon by adding the following new value to the preceding registry key:
Value name: PipeRetries Data type: REG_DWORD Data: Type the number of times to retry.
- Add the time between retries (in milliseconds) by adding the following new value to the preceding registry key:
Value name: PipeRetryInterval
Data type: REG_DWORD
Data: Type the time between retries in milliseconds.
- Quit Registry Editor.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbBug kbenv kbfix kbsms200preSP4fix kbsmsMeter KB287626 |
---|
|