ACC2002: "Specified Index Does Not Exist" Error Message When You Set ADO Recordset Index (287459)
The information in this article applies to:
This article was previously published under Q287459 Moderate: Requires basic macro, coding, and interoperability skills.
This article applies only to a Microsoft Access database (.mdb).
SYMPTOMS
When you use code to select an index and open an ActiveX Data Objects (ADO) recordset, the procedure may fail with the following error message:
Run-time error '-2147217687 (80040e35)'
Specified index does not exist.
CAUSE
This behavior can occur if you are using either the Access OLEDB provider or the MSDataShape provider for the ADO connection for the recordset.
RESOLUTION
To resolve this issue, open your Connection object by using the Microsoft Jet OLE DB provider. If you are running your code in Microsoft Access, you may use CurrentProject.Connection instead of CurrentProject.AccessConnection for your Connection object.
REFERENCESFor more information about about OLE DB and data links, click Microsoft Access Help on the Help menu, type about ole db and data links in the Office Assistant or the Answer Wizard, and then click Search to view the topic. For additional information about differences in data providers, click the article number below
to view the article in the Microsoft Knowledge Base:
281784 ACC2002: Difference Between Connection and AccessConnection Properties
Modification Type: | Major | Last Reviewed: | 11/6/2003 |
---|
Keywords: | kberrmsg kbprb KB287459 |
---|
|