SBS Asbrdcst.dll Initialization Error Is Caused By ARCserve 6.6 (287410)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0

This article was previously published under Q287410

SYMPTOMS

After you have installed ARCserve 6.6 Standard Version on a computer running Microsoft BackOffice Small Business Server (SBS) 4.0, the following error message may appear when you start the computer:

liccheck.exe
Asbrdcst.dll initialization failed
wsock32.dll failed. This process is terminating abnormally.

CAUSE

This behavior can occur because ARCserve 6.6 is not compatible with Small Business Server.

RESOLUTION

To resolve this behavior, uninstall ARCserve 6.6, and then install the version designed for SBS.

MORE INFORMATION

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry



WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


To manually uninstall ARCserve Version 6.6:
  1. Stop all ARCserve engines.
  2. Remove the ARCserve directory.
  3. Start Registry Editor (Regedt32), and then delete the following keys:

    HKEY_LOCAL_MACHINE/Software/ARCserve
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASDBEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASDiscoverySvc
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASJobEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASMsgEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASTapeEngine
  4. Restart the computer, and then check Event Viewer for any ARCserve errors.

To uninstall ARCserve 6.5:
  1. Run the ARCserve uninstall utility.
  2. Start Registry Editor (Regedt32), and make sure the following keys have been deleted:

    HKEY_LOCAL_MACHINE/Software/ARCserve
    HKEY_LOCAL_MACHINE/Software/DiscoveryImplementationList
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASDBEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASDiscoverySvc
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASJobEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASMsgEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/ASTapeEngine
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/cheysaq
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services Cheyenne Alert Notification Server

    NOTE: If the Data Migration option was installed, then delete these keys:

    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/CheyenneDME
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/CheyenneDMP
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/CheyenneDMSHEXT
    HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/CheyenneFSM

  3. In the Winnt\System32 directory, turn off the Read Only attribute of the following files and then delete them:

    CHEYPROD.DLL
    CSTOOL.DLL
    ASBRDCST.DLL
    CHEYSAQ.EXE
    ASDSCSVC.EXE
  4. Restart the computer, and then check Event Viewer for any ARCserve errors.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.


For information about how to contact Computer Associates, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:10/1/2003
Keywords:kbprb KB287410