"Verify that the specified transform paths are valid" error message when you run the Setup program for Office XP from a command line (287064)



The information in this article applies to:

  • Microsoft Office XP Professional
  • Microsoft Office XP Standard
  • Microsoft Office XP Developer

This article was previously published under Q287064

SYMPTOMS

When you run the Setup program for Microsoft Office XP from a command line, and you use a transform file to customize the installation of System Files Update, Office XP may not be installed and you may receive the following error message:
Verify that the specified transform paths are valid.

CAUSE

This behavior occurs if both of the following conditions are true:
  • You create a transform for System Files Update by using the Microsoft Office Custom Installation Wizard (CIW).

    -and-
  • You specify the transform on the command line along with Setup.exe.

    Example: setup.exe TRANSFORMS="C:\My Documents\New Custom Setup File.MST" /qb-
Transforms specified on the command line are ignored during System Files Update installation. When System Files Update finishes and the computer restarts, Microsoft Windows Installer attempts to use the specified transform with the Office installation. Because the transform was created with an .msi package different from the Office .msi, Setup cannot continue and you receive the error message described in the "Symptoms" section of this article.

RESOLUTION

To resolve this issue, follow these steps:
  1. Remove (uninstall) System Files Update. To do this, follow these steps:

    NOTE: If Microsoft Internet Explorer was updated by System Files Update, it will not be removed when you remove System Files Update.
    1. Click Start, point to Settings, and then click Control Panel.
    2. In Control Panel, double click Add/Remove Programs.
    3. On the Install/Uninstall tab, click Microsoft Office System Files Update in the software list, and then click Add/Remove.
    4. In the Microsoft Office System Files Update Maintenance Mode dialog box, click Uninstall System Files Update - Remove Microsoft Office System Files Update from this computer, and then click Next.
    5. In the Are you sure you want to remove Microsoft Office System Files Update? dialog box, click Yes.
    6. On the Microsoft Office System Files Update has been removed from your computer message box, click OK.
    7. In the Add/Remove Programs Properties dialog box, click OK.
  2. Use a text editor to open the Office XP Setup.ini file.

    NOTE: Before you edit the Setup.ini file, make a backup copy.
  3. In the [SystemPackOptions] section, type TRANSFORMS="drive\path\transform name.MST", where drive\path is the complete path to the custom transform, and where transform name is the file name of the custom transform.
  4. On the File menu, click Save.
  5. Start Office Setup from the command line with a command similar to the following:

    drive\path\Setup.exe /spforce

    NOTE: The /spforce switch used if the preceding command forces the reinstallation of System Files Update.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When you create a transform file with the Custom Installation Wizard, the You have completed the Custom Installation Wizard page of the wizard displays a sample Office Setup command similar to the following:

setup.exe TRANSFORMS="C:\My Documents\New Custom File.MST" /qb-

This command-line example is incorrect. Transforms for System Files Update can be specified only in the [SystemPackOptions] section of the Setup.ini file.

When you attempt to install Office XP by using a transform for System Files Update, System Files Update Setup runs and may install Internet Explorer 5.0. To remove System Files Update and Internet Explorer 5.0, use the Add/Remove Programs utility in Control Panel.
When you run the Office XP Setup from the command line, use the /spforce switch if you want to prevent System Files Update Setup from updating the computer with Internet Explorer 5.0.

Modification Type:MinorLast Reviewed:12/5/2005
Keywords:kbtshoot kbbug kberrmsg kbnofix KB287064