XADM: Error Message Updating Free and Busy Data in Exchange 2000 Server (286783)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q286783

SYMPTOMS

When a Microsoft Outlook user connects to a mailbox on an Exchange 2000 Server computer, the user may receive the following error message:
Unable to update public free/busy data. Could not complete operation. One or more parameter values are not valid.

CAUSE

This issue can occur if the user's legacyExchangeDN attribute's delimiters in Active Directory are either stored in all uppercase letters or have partial uppercase letters. Examples of the delimiters in the legacyExchangeDN attribute appearing in uppercase are as follows:

All Uppercase Delimiters:

/O=ORG NAME/OU=SITE NAME/CN=RECIPIENTS/CN=AD USERS/CN=USERS/CN=USER NAME

Partial Uppercase Delimiters:

/O=ORG NAME/OU=SITE NAME/CN=RECIPIENTS/cn=AD USERS/cn=USERS/cn=USER NAME

RESOLUTION

To resolve this issue, use one of the following methods:
  • Contact Microsoft Product Support Services to obtain the Fbfix.zip file. This file contains the files that are necessary to resolve this issue programmatically. For additional information, see the Readme.txt file located in Fbfix.zip.
  • Use the Adsiedit tool that is included with the Microsoft Windows 2000 Support tools to change the legacyExchangeDN attribute.

    WARNING: Using Adsiedit incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Adsiedit can be solved. Use Adsiedit at your own risk.

    To use Adsiedit to change the legacyExchangeDN attribute:
    1. Click Start, point to Programs, point to Windows 2000 Support Tools, and then click ADSI Edit.
    2. In ADSI Edit, locate the user who is experiencing this issue (the user should be located under the domain tree), right-click the user, and then click Properties.
    3. Click the Attributes tab, and then click either Optional or Both to view the properties of the attribute.
    4. In the Select a property to view list, click the legacyExchangeDN attribute.
    5. Copy the entire entry in the Value box into the Edit Attribute box.
    6. Change the values that follow the delimiters to lowercase letters. For example, change

      /O=ORG NAME/OU=SITE NAME/CN=RECIPIENTS/CN=AD USERS/CN=USERS/CN=USER NAME

      to:

      /o=ORG NAME/ou=SITE NAME/cn=RECIPIENTS/cn=AD USERS/cn=USERS/cn=USER NAME

    7. Click Set to set the changes to the legacyExchangeDN attribute.
    8. Repeat the preceding steps for the mailbox of each user who is experiencing this issue.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kberrmsg kbprb KB286783