Exchange Server databases on cluster fail to mount after failing over with Error c1041724 in Exchange 2000 Server (286702)



The information in this article applies to:

  • Microsoft Exchange 2000 Enterprise Server

This article was previously published under Q286702

SYMPTOMS

When you run Exchange 2000 in a clustered environment, Exchange Server services start on one node, but when you fail the Exchange 2000 resource group over to the other node, the databases do not mount, and the following error message may be displayed in Exchange System Manager:
The Database failed to mount: C1041724

CAUSE

This issue can occur because a maximum of four storage groups can exist on an Exchange 2000 computer at one time; this behavior is by design. If there are more than four storage groups, the databases cannot mount.

For example, you have two nodes in a cluster called "Node1" and "Node2", and there are two Exchange Server virtual servers called "EXVS1" and "EXVS2". Each virtual server has three storage groups. When EXVS1 is owned by Node1 and EXVS2 is owned by Node2, the configuration functions as expected. However, if EXVS1 fails over to Node2, none of the databases in EXVS1 start because the total number of storage groups exceeds the maximum of four.

RESOLUTION

To resolve this issue, decrease the number of storage groups that one node can own at any one time to account for failover conditions (less than or equal to four). After you decrease the number of storage groups, restart the store service.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

222989 Relationship between storage groups, databases, and yransaction logs

251123 Maximum number of storage groups in Exchange 2000 for database capacity planning


Modification Type:MajorLast Reviewed:1/12/2006
Keywords:kberrmsg kbprb KB286702