You receive an error message when you try to enable the GPS features in Streets and Trips or in MapPoint (286509)



The information in this article applies to:

  • Microsoft Autoroute 2006 English (United Kingdom)
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft MapPoint 2004 North American Maps
  • Microsoft MapPoint 2002
  • Microsoft MapPoint 2001
  • Microsoft Streets & Trips 2006
  • Microsoft Streets & Trips 2005
  • Microsoft Streets & Trips 2004
  • Microsoft Streets and Trips 2003
  • Microsoft Streets & Trips 2002
  • Microsoft Streets and Trips 2001

This article was previously published under Q286509

SYMPTOMS

When you try to enable the Global Positioning System (GPS) features in Microsoft Streets and Trips or in Microsoft MapPoint, you may receive the following error message:
No GPS device found on this machine. Verify your GPS device is connected and turned on. Choose Configure GPS Receiver from the GPS menu to ensure that your device is attached properly.

CAUSE

This issue may occur if one of the following conditions is true:
  • The GPS device is not plugged into your computer.
  • The GPS add-in is not configured to the correct port.
  • The GPS device is not set to NMEA 2.0 compliance.
  • The GPS device is plugged into the communications (COM) port that is being used by another program.
  • The computer has infrared ports that have the same interrupt request (IRQ) as the COM port.
  • The GPS device uses a program that emulates the communications (COM) port or creates a virtual COM port.
  • The GPS device uses a serial-to-universal serial bus (USB) port adaptor.
  • The GPS device connects to your computer through the USB port.

RESOLUTION

Make sure that the GPS device is configured correctly

  1. On the Tools menu in Streets and Trips or in MapPoint, point to GPS, and then click Configure GPS Receiver.
  2. Select an available communications (COM) port from the list, and then click Next.
  3. Click OK.
The device must meet the following requirements:
  • The INTERFACE should be NMEA/NMEA.
  • The Standard should be NMEA 0183 2.0.
  • The baud should be 4800.

Examine the GPS device in HyperTerminal

  1. Start HyperTerminal.
  2. On the Make new connection screen, type test in the field name, and then click OK.
  3. On the next screen, in the connect using box, click Direct to Com X where X is either 1 or 2, and then click OK.
  4. On the Port Setting screen, change Bits per second to 4800 and flow control to none.
  5. Click OK.
At this point, you should start seeing a continual stream of data that looks similar to the following:

$GPRMB,A,,,,,,,,,,,,V*71
$GPGGA,225224,3400.000,N,06854.375,E,1,07,2.0,638.3,M,-37.5,M,,*6D
$GPGSA,A,3,06,10,17,,22,23,,26,30,,,,4.3,2.0,3.0*33
$GPGSV,3,1,09,06,86,096,51,10,18,043,40,17,49,307,47,21,04,225,00*74
$GPGSV,3,2,09,22,14,310,39,23,40,223,46,24,04,081,00,26,37,119,45*7B
$GPGSV,3,3,09,30,24,202,42,,,,,,,,,*43
$PGRME,15.0,M,22..5,M,15.0,M*1B
$PGRMM,WGS 84*06

If the data is clearly garbled, as in the following

lkdxflkhglkjhflkllkj^%^%#$*(%)%)()($)()(___$%()*)#$%___%(*)#(*()*
#*#$(*)(*$^________$^(
*($*$(^________$#*^%)$
#$*(!%*($_^++$+OI{*U{NE(R(){E09[b*%}*$#+NB*6NB8646n__*^4n0b5e796n3876
__%*($N+BW)$_^N^N0964w--___#(*^%NB+W{$=6n0BW(*n4){)(Wu6n

there is probably a communication problem between the GPS and the computer.

Occasionally, problems such as these can be resolved by modifying the settings of the GPS or the serial port. If this does not resolve the issue, contact your GPS manufacturer.

Clean boot the computer

To do this, use the appropriate method for your version of Microsoft Windows.

Microsoft Windows Millennium Edition (Me)

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective startup.
  3. Click to clear all the check boxes under Selective startup.
  4. On the Startup tab, click to select the *StateMgr check box.
  5. Click OK.
  6. When you are prompted to restart your computer, click Yes.
  7. After the computer restarts, click Start, click Run, type msconfig in the Open box, and then click OK.

    Important Look closely at the General tab to make sure that the check boxes that you cleared are still cleared. Go to step 6 if none of the check boxes are selected. If you see an unavailable check box that appears dimmed, your computer is not truly "clean-booted" and you may need help from the manufacturer of the program that puts a check mark back into Msconfig.
  8. After you verify that your computer is clean-booted in step 7, you can isolate the issue. If the original issue does not occur again after the clean boot, select one item at a time under Selective startup, and then restart the computer to see if the additional entry reproduces the original issue.

How to return from a clean boot state

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Normal startup.
  3. Click OK.
  4. When you are prompted to restart your computer, click Yes.

Microsoft Windows 98

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective Startup, and then click to clear the following check boxes:
    • Process Config.sys File
    • Process Autoexec.bat File
    • Process Winstart.bat File (if it is available)
    • Process Win.ini File
    • Load Startup Group Items
  3. Click OK.
  4. When you are prompted to, restart the computer.
For additional information about how to perform a clean boot in Windows 98, click the following article number to view the article in the Microsoft Knowledge Base:

192926 How to perform clean-boot troubleshooting for Windows 98

Microsoft Windows 95

  1. Restart the computer.
  2. When you receive the "Starting Windows 95" message, press the F8 key, and then click Command Prompt Only on the Startup menu.
  3. At the command prompt, type win, and then press ENTER. Press and hold down the SHIFT key until the Windows startup sequence is completed.
  4. Disable any antivirus or disk tool programs that are installed on the computer.

    For information about how to disable these programs, see the printed or online documentation for the program.
  5. Quit all the programs that are running except Explorer and Systray. To do this, press CTRL+ALT+DELETE, click the program that you want to quit, and then click End Task. If you receive a message that states that the program is busy or is not responding, click End Task again. Repeat this step to quit all the programs except Explorer and Systray.
For additional information about how to perform a clean boot in Windows 95, click the following article number to view the article in the Microsoft Knowledge Base:

177604 Multimedia: Troubleshooting using clean boot of Windows 95

Decrease the COM port buffer

The buffer settings are located in the Device Manager under the appropriate COM port's Advanced Settings button. Decreasing these settings could allow for a GPS to be seen or to function more reliably in the program.

Issues that are BIOS related

This section contains suggestions for changing settings in the basic input/output system (BIOS). Incorrectly setting some options in the BIOS could cause significant problems on the system. See your reference manual when you are working in the BIOS and use caution.

Some BIOS support what is called "serial timeout." If this support is turned on, problems may occur. Set this to OFF. Make sure that the resource hexadecimal address and IRQ match those in Device Manager also.

Also note that Infrared ports can frequently cause trouble with GPS detection. If the option is available, DISABLE the infrared port.

Check IR port and modem settings

Sometimes you may have to disable the IR port or to disable or remove an internal modem (scanner card, bus mouse card, and so on) which may be sharing a virtual COM port with the computers external serial port. For example, if a modem that is installed uses COM3, you may not be able to see a GPS device in the software if the GPS is attached to COM1.

Look for and remove ghost devices

To remove ghost devices, use the following methods in the order that they appear in.

Check Device Manager

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Device Manager tab.
  4. Double-click Human Interface Devices.
  5. Note the entries that are listed under this type.
  6. Double-click Sound, video and game controllers.
  7. Note the entries that are listed under this type.
  8. Double-click Universal Serial Bus controllers.
  9. Note the entries that are listed under this type.
  10. To close the Device Manager, click Cancel.

Restart your computer in Safe Mode

Use the appropriate steps for your operating system.

Windows 95
  1. Click Start, and then click Shut Down.
  2. Click Restart The Computer, and then click Yes.
  3. When you receive the "Starting Windows 95" message, press F5.
  4. When Windows is finished loading, close the message about Safe Mode.
Windows 98 and Windows Millennium Edition (Me)
  1. Click Start, and then click Shut Down.
  2. Click Restart The Computer, and then click Yes.
  3. Press and hold the SHIFT key when the POST (Power on Self Test) is completed.
  4. When Windows finishes loading, close the "Safe Mode" message.

Check Device Manager and remove duplicate devices

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Device Manager tab.
  4. Double-click Human Interface Devices.
  5. Remove any duplicate device from the list made in section 1.
  6. Double-click Sound, video and game controllers.
  7. Remove any duplicate device from the list made in section 1.
  8. Double-click Universal Serial Bus controllers.
  9. Remove any duplicate device from the list made in section 1.
  10. To close the Device Manager, click Close.
  11. Restart the system if you are not prompted to.
Note Let the system restart in Normal mode.

Examine the installation of the add-on

Remove the GPS add-on

  1. Click Start, point to Settings, and then click Add/Remove Programs.
  2. Double-click Microsoft GPS Add-on V1.01.
  3. Follow the prompts that appear on the screen to remove the GPS add-on.
Note If Microsoft GPS Add-on V1.01 is not listed, go to the "Install the GPS add-on" section.

Install the GPS add-on

  1. With the installation disk in the drive, double-click My Computer.
  2. Right-click the CD (CD1), and then click Install GPS.
  3. Follow the prompts that appear on the screen to install the GPS add-on.

Try a different COM port

  • Try to set up the GPS on a different COM port.
  • Remove any conflicting software in Add/Remove Programs. This could include modem software and infrared support software, specifically infrared support for Windows 95 version 2.0.
  • Look for and remove any software that is for infrared or COM port use.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:4/19/2006
Keywords:kberrmsg kbprb KB286509