Business Desk Fails to Load with Unspecified Error (0x80004005) (286388)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q286388

SYMPTOMS

When you start Business Desk, the following error message occurs:
Error Type: (0x80004005) Unspecified error /BizDesk/navtree.asp, line 59

CAUSE

This error occurs when Access Control Lists (ACLs) in the Business Desk files contain a domain global group.

Business Desk uses the Win32 API GetEffectiveRightsFromAcl to determine if a user has access to Business Desk. GetEffectiveRightsFromAcl returns an error when you use global domain groups.

RESOLUTION

To resolve this problem, apply the fix that is described in the following Knowledge Base article:

286360 GetEffectiveRightsFromAcl() Function Causes 'ERROR_NO_SUCH_DOMAIN' Error Message

WORKAROUND

Do not use global groups to assign permissions to the Business Desk module files.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

Modification Type:MajorLast Reviewed:10/18/2002
Keywords:kbbug KB286388