Clients Unable to Connect to Web Site Published from Behind Proxy If Alternate Port Is in Use (286364)



The information in this article applies to:

  • Microsoft Proxy Server 2.0

This article was previously published under Q286364

SYMPTOMS

When you are hosting a Web site behind a proxy server or any device that serves as a middleman between the client and server (i.e. local director or other device with rudimentary proxy functions, and the Web site is using a port other than the default port 80, some clients may not be able to connect to the Web site by using its URL.

CAUSE

This behavior can occur when the URL of the Web site is not specified correctly. The correct syntax for a URL request is:

http://servername/directory/

Note the trailing slash (/). If this trailing slash is left off, redirect messages from the Internet Information Server (IIS) server to the client will include the trail as well as the port number. If this port number differs from the port that the proxy server is listening on for IIS traffic, then the proxy server will remove it before forwarding the redirect message to the client.

RESOLUTION

To resolve this behavior, either use the correct syntax when you request a URL, or configure the Web site to use the default port 80.

Modification Type:MajorLast Reviewed:2/10/2002
Keywords:kbprb KB286364