Visio2000: Error Message: "An Error 1060 - The Specified Service Does Not Exist as an Installed Service..." When You Perform an AutoDiscovery and Layout (286014)



The information in this article applies to:

  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q286014

SYMPTOMS

When you perform an AutoDiscovery and Layout for a network diagram, you may receive the following error messages:
An error 1060 - (the specified service does not exist as an installed service.) occurred while trying to open the MSSQLServer service.


The MSDE component is not properly installed and the solution failed to load. Please make sure it is properly installed.

CAUSE

This behavior can occur is caused when the Microsoft Data Engine (MSDE) is missing or damaged.

RESOLUTION

If you have MSDE installed, MSDE needs to be removed and reinstalled. You can verify whether MSDE is installed by looking in Add/Remove Programs in Control Panel.

To resolve this issue, follow these steps. If a particular portion of this resolution does not apply to you, skip the section and continue.
  1. Stop SQL Server Service Manager.
  2. Remove MSDE.
  3. Reinstall MSDE.
  4. Restart SQL Server Service Manager.
Stop SQL Server Service Manager To stop the SQL Server Service Manager, follow these steps:
  1. Quit Visio, and then open SQL Server Service Manager by double-clicking the MSSQLServer icon in the system tray.
  2. In the SQL Server Manager dialog box, click to clear the Auto-start service when OS Starts check box.
  3. Stop MSSQLServer Service manager, and click Yes when you are asked if you are sure that you want to stop SQL Server Manager.
  4. Right-click the MSSQLServer icon in the system tray, and then click Remove Startup shortcut.
  5. Restart Windows.
Remove MSDE To remove MSDE, follow these steps:
  1. Click Start, point to Settings, click Control Panel, and then double-click Add Remove Programs.
  2. Select MSDE, and then click Add/Remove.
  3. Click No to ALL when you are prompted to remove the shared file Replprov.dll.
  4. Open Windows Explorer, delete the MSSQL7 folder, and then click Yes to confirm that you want to delete it.
  5. Click Yes again.
Reinstall MSDE To reinstall MSDE, follow these steps:
  1. Insert the Microsoft Visio 2000 Enterprise Edition CD into your CD-ROM or DVD-ROM drive.
  2. Click Start and click Run.
  3. In the Open box, type:

    <CD>:\Install\bin\sp\MSDE\MSDEx86.exe -s -a -f1 "<CD>:\Install\bin\sp\MSDE\unattend.iss"

    where <CD> is the CD-ROM or DVD-ROM drive letter on your system.
  4. Click OK.

    MSDE will require a few minutes to install.
  5. After installation completes, restart Windows.

    NOTE: On systems running Microsoft Windows NT and Microsoft Windows 2000, open Task Manager by pressing CTRL+ALT+DEL, and wait for MSDEx86.exe to disappear from the Processes list.
Restart SQL Server Service Manager To restart SQL Server Service Manager, follow these steps:
  1. Open SQL Server Service Manager by double-clicking the MSSQLServer icon.

    NOTE: If the MSSQLServer icon does not appear in the system tray, you may have to reinstall MSDE again.
  2. In the SQL Server Manager dialog box, click to select the Auto-start service when OS Starts check box.
  3. Start SQL Server Service Manager by clicking Start/Continue.

Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kbinfo KB286014