WMI Win32_POTSModem and Win32_POTSModemToSerialPort Return No Instances (285895)



The information in this article applies to:

  • the operating system: Microsoft Windows 95
  • the operating system: Microsoft Windows 98

This article was previously published under Q285895

SYMPTOMS

When you attempt to retrieve instances from the Windows Management Instrumentation (WMI) Win32_POTSModem and Win32_POTSModemToSerialPort classes in Windows 95 or Windows 98, no instances are returned.

CAUSE

This problem occurs because the WMI provider does not retrieve Telephony API (TAPI) information.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Version         Size     File name    Platform
   ----------------------------------------------------------
   01/26/2001  1.50.1085.0048  513,488  Q285895.EXE  Intel
				
NOTE: This hotfix is available only for WMI 1.5 in Windows 95 and Windows 98.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Client Hotfix Bundle Installation

Method 1: Using the Hotfix Installer

  1. Copy the Q285895.exe hotfix installer file to a local subfolder on the affected computer that is running Windows 95 or Windows 98, or to a share on your network. The Q285895.exe file is a Microsoft Windows Installer file that updates a WMI component on your computer.
  2. Run the Q285895.exe file and follow the instructions in the wizard. You can run this file in Quiet mode by using the /s switch.

Method 2: Manual Installation

  1. Copy the Q285895.exe hotfix installer file to a local subfolder on the affected computer that is running Windows 95 or Windows 98, or to a share on your network. The Q285895.exe file is a Microsoft Windows Installer file that updates a WMI component on your computer.
  2. Run the Q285895.exe file with the /X (extract) switch.
  3. Click the Cimwin32.dll file, and then click OK.
  4. Select a location to which to save the file, and then click Save.
  5. Stop the Winmgmt process. To do this, click Start, click Run, type winmgmt.exe /kill, and then click OK.
  6. Replace the Cimwin32.dll file in the Windows\System\Wbem folder with the version that you extracted from the hotfix installer file.
  7. Winmgmt is started on demand; you do not need to restart it.

Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbprb kbQFE KB285895