XADM: Exchange 2000 Details Templates Unable to Display Multi-Value Active Directory Attributes (285887)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q285887

SYMPTOMS

Certain multi-valued attributes of a Windows 2000 Active Directory User or Contact object may not be displayed when you view the object's details in the Exchange 2000 Server global address list. The global address list may not contain any information even though the data is displayed when you view the object in the Windows 2000 Active Directory Users and Computers snap-in.

CAUSE

In Windows 2000 Active Directory, the following user and contact attributes have been updated to enable you to specify multiple values:

Active Directory FieldExchange Template FieldActive Directory Attribute Name
Home OtherHome 2Phone-Home-Other
Telephone OtherBusiness 2Phone-Office-Other
Pager OtherN/APhone-Pager-Other
Web Page OtherN/AWWW-Page-Other

These values can be entered and are displayed correctly in the Active Directory Users and Computers snap-in. However, the Exchange 2000 User and Contact details templates have not been updated to enable you to add multi-valued attributes. For example, the Home 2 and Business 2 fields that are listed in the preceding table use an Edit control. This control is capable of displaying only a single value. The last two Active Directory attributes that are listed in the preceding table do not have a representative field on the template form. You must add these attributes manually.

RESOLUTION

  1. Run update.exe from the latest Exchange 2000 service pack (SP3 or later) to update the files on the server.
  2. Run update /forestprep from the latest Exchange 2000 service pack (SP3 or later) to update the details templates in Active Directory.
  3. Revert to the new templates using the following steps:
  1. Start System Manager. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  2. In the console tree, double-click Recipients, double-click Details Templates to expose the language list, and then double-click a language that is used by your clients.
  3. In the details pane, double-click each template that you want to revert.
  4. In the Properties dialog box, click the Templates tab.
  5. Click "Original" to allow the new templates take effect.

Note This operation permanently overwrites any custom changes that you or another administrator made to a template.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kbpending KB285887