SideWinder Error Message: Error While Trying to Initialize Forces, Please Reinstall the Software for This Hardware (285877)



The information in this article applies to:

  • Microsoft SideWinder Force Feedback 2
  • Microsoft SideWinder Force Feedback Wheel USB
  • Microsoft SideWinder game pad Pro
  • Microsoft SideWinder Plug and Play game pad USB
  • Microsoft SideWinder Precision 2
  • Microsoft SideWinder Precision Racing Wheel
  • Microsoft SideWinder Strategic Commander

This article was previously published under Q285877
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

When you attempt to install any of the game controllers listed at the beginning of this article, in Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), or Microsoft Windows Millennium Edition (Me) you may experience one or more of the following symptoms:
  • The game controller is displayed in the Device Manager tool, but is not displayed in the Game Controllers or Gaming Options tool.
  • The game controller is displayed in the Device Manager tool and the Game Controllers or Gaming Options tool, but when you attempt to test the forces, you receive one of the following error message:
    • Error while trying to initialize forces, please reinstall the software for this hardware.
    • An unknown error occurred while trying to initialize forces.
  • When you attempt to open the Game Controller or the Gaming Options tool, you receive the following error message:
    There is not enough system resources to open this application or the application is not installed properly, please reinstall the application.

CAUSE

This behavior can occur if some system files are not the correct version.

RESOLUTION

To resolve this issue, use the System File Checker tool to restore the system files in the following table.

NOTE: To extract the files, you need to have your Windows 98 or Windows 98 SE installation CD-ROM.
File NameWin98 VersionWin98SE VersionLocation of file
hid.dll4.10.19984.10.2222C:\Windows\System
hidclass.sys4.10.19984.10.2222C:\Windows\System32\Drivers
hidparse.sys4.10.19984.10.2222C:\Windows\System32\Drivers
hidusb.sys4.10.19984.10.2222C:\Windows\System32\Drivers
hidvkd.sys4.10.19984.10.1998C:\Windows\System32\Drivers
mmdevldr.vxd4.10.19984.10.1998C:\Windows\System
openhci.sys4.10.19984.10.2222C:\Windows\System32\Drivers
uhcd.sys4.10.19984.10.2222C:\Windows\System32\Drivers
usbd.sys4.10.19984.10.2222C:\Windows\System32\Drivers
usbhub.sys4.10.19984.10.2222C:\Windows\System32\Drivers

How to Use the System File Checker Tool

To use the System File Checker tool to extract a compressed file from Windows 98 or Windows 98 SE:
  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.
  2. On the Tools menu, click System File Checker.
  3. Click Extract one file from installation disk, type the name of the file that you want to extract in the Specify the system file you would like to restore box, and then click Start.
  4. In the Restore From box, type the path to the Win98 folder on the Windows 98 CD-ROM, type the destination folder in the Save File In box if necessary, and then click OK.
  5. Click OK, click OK, and then click Yes when you are prompted to restart your computer.
NOTE: If you do not specify a source cabinet (.cab) file in the Restore From box, System File Checker first searches for the file you are extracting in the specified folder (outside of a cabinet file). System File Checker then searches all cabinet files, sorted by MS-DOS directory order, in the specified folder. System File Checker extracts the first instance of the file it finds.

To determine the order in which System File Checker searches cabinet files, type dir at a command prompt in the folder in which you want System File Checker to search.

How to Extract Protected Files in Microsoft Windows Me

For additional information about how to extract protected files in Windows Me, click the article number below to view the article in the Microsoft Knowledge Base:

265371 How to Extract and Replace a Protected File in Windows Me

MORE INFORMATION

If you continue to experience this issue, download and install the latest version of Microsoft DirectX.

For additional information about how to download and install DirectX, click the article number below to view the article in the Microsoft Knowledge Base:

179113 How to Download and Install DirectX


Modification Type:MajorLast Reviewed:6/16/2006
Keywords:kbHardware kbprb KB285877