XCON: MTA Does Not Completely Start After You Receive Windows NT Error 11004 (285350)



The information in this article applies to:

  • Microsoft Exchange Server 5.5 SP4

This article was previously published under Q285350

SYMPTOMS

The Microsoft Exchange Message Transfer Agent (MTA) does not start after you upgrade to Service Pack 4 (SP4). The MTA generates the following MTA event IDs:

9321
An RPC communications error occurred. An attempt to listen over RPC has failed. NT Error: 11004. [ BASE IL MAIN BASE 1 504] (14)

9266
A fatal system error occurred while initializing the MTA. Reboot the computer. If that does not work, contact Microsoft Technical Support. [4 BASE IL MAIN BASE 1 173] (16)

CAUSE

This problem may occur with a multihomed server in which one of the active network adapters cannot communicate over remote procedure call (RPC) with other servers in the site. This issue may occur if RPC is not available, or if the network adapter is attached to another local area network (LAN).

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

You can also download and apply the post-SP4 MTA fixes that are found in the following article:

283238 XADM: Exchange Server 5.5 Post-Service Pack 4 Message Transfer Agent Fixes Available

Component: MTA

The English version of this fix should have the following file attributes or later:

File nameVersion
Dbserver.sch5.5.2654.54
Dcprods.cat5.5.2654.54
Emsmta.exe5.5.2654.54
Ems_rid.dll5.5.2654.54
MTacheck.exe5.5.2654.54
Infoplog.cfg5.5.2654.54
Mtamsg.dll5.5.2654.54
Mtaperf.dll5.5.2654.54
P42.tpl5.5.2654.54
P772.tpl5.5.2654.54
P2.xv25.5.2654.54
X400om.dll5.5.2654.54

NOTE: Because of file dependencies, this hotfix requires Microsoft Exchange Server version 5.5 Service Pack 4.

WORKAROUND

To work around this problem, make sure that all enabled network adapters can communicate with the other servers in the site that are using RPC. You may have to disable any network adapters that do not provide connectivity to the servers in the Exchange Server site.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.

MORE INFORMATION

This behavior is by design for a cluster server because the available network adapters must be able to communicate with the other servers in the site that are using RPC.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbExchange550preSP5fix kbfix kbQFE KB285350