Visio2000: Missing Toolbars or Menu Bar (285004)



The information in this article applies to:

  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q285004
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In Microsoft Visio, a toolbar that is enabled may not be visible, the menu bar may be missing, or buttons may be missing from a toolbar.

CAUSE

This issue may occur if you accidentally drag a toolbar or menu bar off the visible screen.

A similar issue may occur if the display resolution is too low to display all the buttons on a toolbar, or if you put two toolbars on the same row. Visio hides some buttons under these conditions.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, enable a display resolution of 800 x 600 pixels or higher, or move one of the toolbars to its own row. If this doesn't restore the toolbar or menu bar, follow these steps to restore the default settings:
  1. Close all instances of Visio.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Select the following subkey (folder) in the left pane of Registry Editor:

    HKEY_Current_User\Software\Visio\Visio 2000\Toolbars

  5. On the Edit menu, click Delete to delete the Toolbars subkey.
  6. Click Yes when you are prompted to confirm the deletion.
  7. On the Registry menu, click Exit.

    The Registry Editor automatically saves your changes.
When you start Visio, it re-creates the deleted subkey and restores toolbars and menu bars to their default locations.

Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kbprb KB285004