The "Automatically Detect ISA Server" Option in the Firewall Client Is Unavailable (284690)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

This article was previously published under Q284690

SYMPTOMS

When you install the firewall client on either a Microsoft Windows 95-based or Microsoft Windows NT 4.0-based workstation, you can observe that the Automatically Detect ISA Server option in the Firewall client options is unavailable. Even though you have already enabled Automatic Discovery on the server, when you restart the server, this option is still not enabled.

CAUSE

This behavior can occur because Winsock Proxy Autodetect (WSPAD) relies upon DNS for the transfer of information. However, if DNS fails, client computers that support remoting of Winsock calls can still use WSPAD. Because Windows 95-based and Windows NT 4.0-based workstation clients do not support remoting of Winsock calls, the Automatically Detect ISA Server option is unavailable.

STATUS

This behavior is by design.

MORE INFORMATION

Because remoting is supported on Microsoft Windows 98-based and Microsoft Windows 2000-based clients, the Automatically Detect ISA Server option is available to those clients.

For additional information about WSPAD Support, click the article number below to view the article in the Microsoft Knowledge Base:

260210 Description of WinSock Proxy Auto Detect Support


Modification Type:MinorLast Reviewed:1/30/2006
Keywords:kbenv kbprb KB284690