OL97: Custom Form Is Not Received When Sent Over the Internet (284297)



The information in this article applies to:

  • Microsoft Outlook 97

This article was previously published under Q284297

SYMPTOMS

You send a custom mail message form over the Internet using an Internet Service Provider (ISP), or an Internet Mail Service on a Microsoft Exchange Server computer, but the custom form is not preserved when the recipient receives it.

CAUSE

Outlook custom forms are stored in a rich text format (RTF), so if the item encounters anything during the transmission process that does not support RTF, the form definition is lost.

NOTE: This requirement is not related to the format of the mail message. This applies to custom mail message forms where the body of the message is formatted for plain text or Microsoft Outlook Rich-Text.

MORE INFORMATION

To send forms over the Internet, you must enable the Send form definition with item option in the form. Even if you publish the form in two separate organizations and choose to not send the form definition with the item, the message class field is stripped, and therefore, the message opens as a standard mail message when it is received. For additional information about message class fields, click the article number below to view the article in the Microsoft Knowledge Base:

170301 OL97: How to Update Existing Items to Use a New Custom Form

In addition to enabling the Send form definition with item option, also take the following information into account:
  • If you are sending through a Microsoft Exchange Server Internet Mail Connector, the connector must be configured to support Transport Neutral Encapsulation Format (TNEF), which encapsulates the rich text. Contact your Exchange Server administrator to see if this can be done.
  • If you are sending to contacts that are in your Outlook Address Book, or Contacts folder, be sure to enable the "always send to this recipient in Microsoft Outlook rich-text format" setting. To access this setting, open the contact and then double-click the contact's e-mail address.
  • If you are using the Personal Address Book as your address book, enable the Always send to this recipient in Microsoft Outlook rich-text format option. To access this option, open the address book, and double-click the recipient's name to access the properties of the recipient.
  • If the custom mail message is being transferred by one or more ISPs, you must ensure that those providers are not stripping rich text, or TNEF, information from the message.

REFERENCES

For additional information about this issue if you are using Microsoft Exchange, click the article number below to view the article in the Microsoft Knowledge Base:

179722 XCLN: Internet User Cannot Display Form Sent via Internet Mail Service

For additional information about creating solutions with Microsoft Outlook, click the article numbers below to view the articles in the Microsoft Knowledge Base:

166368 OL97: Resources for Custom Forms and Programming

170783 OL97: Questions About Customizing or Programming Outlook


Modification Type:MinorLast Reviewed:3/1/2004
Keywords:kbprb KB284297