Games error message: Stop: Failed - Create Sound Buffer (284212)



The information in this article applies to:

  • Microsoft Links 2001
  • Microsoft MechCommander 2.0 1.0
  • Microsoft MechWarrior 4: Vengeance

This article was previously published under Q284212

SYMPTOMS

When you start Microsoft MechWarrior 4: Vengeance, you may receive the following error message:
STOP:FAILED - (WINERR_one or more arguments are invalid) - Create Sound Buffer
When you try to start Microsoft Links 2001, you may receive the following error message:
STOP: FAILED (0x8878001e - DSERR_CONTROLUNAVAIL) - CreateSoundBuffer

CAUSE

This issue may occur if you have conflicting audio codecs installed on the computer. Or if one or more of the audio codecs are missing or are damaged.

RESOLUTION

To resolve this issue, use the following methods in the order they appear in.

Reduce audio hardware acceleration

To reduce audio hardware acceleration, follow these steps:
  1. Click Start, click Run, type dxdiag in the Open box, and then click OK.
  2. Click the Sound tab.
  3. Under DirectX Features, move the Hardware Sound Acceleration Level slider all the way to the left to the No acceleration setting.
  4. Click Exit.

Update the sound card drivers

Contact the manufacturer of the sound card or the computer to obtain and install the latest version of the driver for the sound card. For information about how to contact the manufacturer of the sound card, see the "More Information" section. Additionally, visit the following Microsoft Windows Update Web site to see whether applicable driver updates are available: To identify the name and the provider of the sound card, follow these steps:
  1. Click Start, click Run, type dxdiag in the Open box, and then click OK.
  2. Click the Sound tab.
  3. Under Device, look for Name, and then look for Provider under Driver.
  4. Click Exit.
If the issue continues to occur after you install the latest sound card drivers, go to the next method.

Remove and then reinstall the audio compression drivers

To remove and then reinstall audio compression drivers in Microsoft Windows 95, in Microsoft Windows 98, or in Microsoft Windows Millennium Edition, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Windows Setup tab, click Multimedia, and then click Details.
  4. Click to clear the Audio Compression check box, and then click OK.
  5. Click Apply.
  6. On the Windows Setup tab, click Multimedia, and then click Details.
  7. Click to select the Audio Compression check box, and then click OK.
  8. Click OK.
  9. Follow the instructions that appear on the screen to finish installing the audio compression drivers.
If the issue continues to occur, go to the next method.

Remove and then reinstall the default codecs

To remove and then reinstall the default codecs, use the following methods in the order that they appear in.

Remove all the default codecs

  1. In Control Panel, double-click Add/Remove Programs.
  2. On the Windows Setup tab, click Multimedia, and then click Details.
  3. Click to clear the Audio Compression check box and the Video Compression check box, and then click OK.
  4. Click OK.

Delete specific codecs and MCI devices

  1. In Control Panel, double-click Multimedia.
  2. Click the Advanced tab or the Devices tab.
  3. Double-click one of the following branches:
    • Audio Compression Codecs
    • Video Compression Codecs
    • Media Control Devices
  4. Double-click the codec that you want to delete or one of the following MCI devices, and then click Remove:
    • CD Audio Device
    • MIDI Sequencer Device
    • Motion Video Device
    • PIONEER LaserDisc Device
    • VISCA VCR Device
    • Wave Audio Device
    Note Do not delete the Microsoft PCM Converter codec.
  5. Repeat steps 3 and 4 to delete all the audio and video codecs and all the MCI devices, except the Microsoft PCM Converter audio codec.
  6. Restart the computer.

Reinstall the default codecs

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Windows Setup tab, click Multimedia, and then click Details.
  4. Click to select the Audio Compression check box and the Video Compression check box, and then click OK.
  5. Click Apply.
  6. Click OK.
  7. Follow the instructions that appear on the screen to finish installing the codecs.

Reinstall MCI devices and additional codecs

  1. In Control Panel, double-click Add New Hardware.
  2. Click Next, click No, and then click Next.
  3. In the Hardware Types box, click Sound, Video, and Game Controllers.
  4. In the Manufacturers box, click Microsoft MCI.
  5. In the Models list, click CD Audio Device (Media Control).
  6. Click Next.
  7. Click Finish.
  8. Repeat the steps 1 through 7 to reinstall all the following MCI devices:
    • MIDI Sequencer Device
    • Motion Video Device
    • PIONEER LaserDisc Device
    • VISCA VCR Device
    • Wave Audio Device
  9. Repeat steps 1 through 7 to reinstall any additional MCI devices or codecs that you want to use.
  10. Restart the computer.

Select the correct playback device in the Multimedia Settings Control Panel

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Multimedia icon in Windows 95 or in Windows 98. Double-click the Sounds and Multimedia icon in Windows Millennium Edition or in Windows 2000.
  3. Select the correct Playback device, if it is not already selected.
If these steps do not resolve the issue, follow the steps that are listed in the following Microsoft Knowledge Base article:

279763 Error Message: Stop:Failed (0xc29b85a0 - WINERR) Set (EAX Reverb Properties, EAX Environment)


Modification Type:MinorLast Reviewed:1/3/2006
Keywords:kbConfig kberrmsg kbprb KB284212