SharePoint Portal Server Setup Does Not Recover If the CD-ROM Is Ejected or the Network Connection Is Lost (284039)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q284039

SYMPTOMS

When you are installing SharePoint Portal Server, Setup may not work, and error messages may be logged in the Errorlog.txt file that are similar to:
Microsoft Search: [2] CSearchSetupEngine::InstallSearch, Failed to register language resources. hr=0x80070057

Microsoft Search: [2] InstallFile, SetupInstallFile failed. File : d:\server\search\.\gthrlog.vbs. GetLastError returns 0x00000015. Retrying copy...

Microsoft Search: [2] RegisterDll, Unable to register/unregister dll C:\Program Files\Common Files\Microsoft Shared\MSSearch\Bin\Msir3jp.dll. Could not load dll. GetLastError()=0x0000007e

[01/24/02,18:48:41] Microsoft Search: [2] CSearchSetupEngine::InstallSearch, Failed to register language resources. hr=0x80070057
At end of the Errorlog.txt file, error messages may also be logged that are similar to:
CPkmSetupComponent::CreateSearchApplication, Cannot CoCreate Search admin object. hr=0x80040154
Microsoft Tahoe Server: [2] CVAIComponent, Error 0x80070001: MimeMap fixup failed
Microsoft Tahoe Server: [2] CVAIComponent::Install, Error fixing up IIS Mime Map.
Microsoft Tahoe Server: [2] CVAIComponent, Error 0x80004005: Failed to stop search
Microsoft Tahoe Server: [0] CVAIComponent::Install, Error setting up VAI.
By default, the Errorlog.txt file is located in the following path:

system_drive\Program Files\Microsoft Integration\SharePoint Portal Server\Logs

NOTE: You can use several files in the preceding folder for troubleshooting.

CAUSE

This problem may occur if the SharePoint Portal Server installation was interrupted, either because the installation CD-ROM was ejected or network connectivity was lost. When you start the installation again, the installation may seem to recover and stop working later, or SharePoint Portal Server may not be installed correctly when Setup is complete.

RESOLUTION

To resolve this problem, run Setup again and click Repair when you are prompted.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:1/3/2003
Keywords:kbbug kberrmsg KB284039