Cannot change computer name after BizTalk is installed (283221)



The information in this article applies to:

  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2002

This article was previously published under Q283221

SYMPTOMS

When you change the computer name on a computer running BizTalk Server 2000 or BizTalk Server 2002, and you restart (reboot) the computer, error messages may occur.

When you attempt to manually start the BizTalk Service in the Microsoft Management Console (MMC), the following error message occurs:
Microsoft Management Console

Could not start the BizTalk Messaging Service service on Local Computer. The service did not return an error. This could be an internal Windows error or an internal service error. If the problem persists, contact your system administrator.
The following error message occurs in the Event Viewer:
Type: Error
User: N/A
Source: BizTalk Server
Category: Document Processing
Event ID: 324

An error occurred in BizTalk Server.

Details:
------------------------------
The service failed to start. Verify that this server is enlisted in a BizTalk Server group.

CAUSE

BizTalk Server 2000 and BizTalk Server 2002 do not support changing the computer name once the product is installed.

STATUS

This behavior is by design.

MORE INFORMATION

Multiple problems can occur in BizTalk Server 2000 and BizTalk Server 2002 when you change the computer name. In addition, BizTalk Server 2000 and BizTalk Server 2002 rely on other products, such as SQL Server and MSMQ that may have problems when you change the computer name. It may be possible to restore BizTalk Server's functionality by renaming the computer back to the original name (when BizTalk Server was installed). This has not been tested by Microsoft and BizTalk Server may still have problems as a result of the name being changed.

Modification Type:MajorLast Reviewed:8/6/2004
Keywords:kbbug kbpending KB283221