Windows NT 4.0 Lprmon Does Not Restart Job If It Receives a "Nack" After Sending a Data File (283015)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q283015

SYMPTOMS

When you use a printer in Windows 2000 that is defined as an LPR printer, a job can be lost if the LPR print monitor (Lprmon) receives a "NACK" response after the data file is sent. This can occur if the destination computer is UNIX-based and the /var folder is full.

CAUSE

Lprmon does not check for the status from the server after sending the data file.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Version        Size    File name   Platform  
   -------------------------------------------
   4.0.1381.7095  21,776  Lprmon.dll  Intel
   4.0.1381.7095  34,064  Lprmon.dll  Alpha
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/19/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB283015