You cannot modify reports if Adobe PDFWriter is the default printer in Access 2002 (282385)



The information in this article applies to:

  • Microsoft Access 2002

This article was previously published under Q282385
Novice: Requires knowledge of the user interface on single-user computers.

This article applies to a Microsoft Access database (.mdb) and to a Microsoft Access project (.adp).

SYMPTOMS

When you run Microsoft Access on a computer that is running Microsoft Windows Millennium Edition (Me) or Microsoft Windows 98, you receive the following error message when you try to print or modify a report:
There was a problem retrieving printer information for this object. The object may have been sent to a printer that is unavailable.

CAUSE

The Adobe Acrobat PDFWriter printer driver is set as the system's default printer. On Microsoft Me-based and Microsoft Windows 98-based computers, the Adobe Acrobat PDFWriter printer driver does not communicate correctly with Microsoft Access when it is set as the default printer.

RESOLUTION

Set another printer driver as the default printer, and then manually select the Adobe PDFWriter printer after you create a report. To do so, follow these steps:

  1. Click Start, point to Settings, and then click Printers.
  2. In the Printers dialog box, right-click a printer other than the Adobe PDFWriter, and then click Set as Default Printer so that the command is checked. Close the Printers dialog box.
  3. Start Microsoft Access, and then open any database.
  4. Create a new report, and open it in Design view.
  5. On the File menu, click Page Setup.
  6. Click the Page tab, and then click Use Specific Printer.
  7. Click the Printer... button, click the arrow in the Name box, and then select the Adobe PDFWriter printer. Click OK twice.
  8. Print your report.

MORE INFORMATION

Microsoft Access relies on a structure that is supplied by the printer driver, called a DEVMODE structure, to determine how reports should be printed. Microsoft Access requests this structure from the operating system, and the printer driver supplies it. On Microsoft Windows Me-based and Microsoft Windows 98-based computers, the Adobe Acrobat PDFWriter printer driver returns an invalid DEVMODE structure to Microsoft Access. When Microsoft Access encounters an invalid DEVMODE structure, it returns the error message that is mentioned in the "Symptoms" section.

This behavior does not occur on computers that are running Microsoft Windows 2000 or Windows NT 4.0.

Steps to Reproduce the Behavior

  1. On a computer that is running Windows Me or Windows 98, install Adobe Acrobat or another program that installs the Adobe PDFWriter printer driver.
  2. Set the Adobe PDFWriter printer as the default printer.
  3. Start Microsoft Access.
  4. Open any database.
  5. Create a new, blank report. Note that you receive the following error message:
    There was a problem retrieving printer information for this object. The object may have been sent to a printer that is unavailable.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:8/10/2004
Keywords:kbReport kbprinters kbtshoot kberrmsg kbprb kbprint KB282385