ACC2002: Data in Replica Sets Does Not Match as Expected After Synchronization (282316)
The information in this article applies to:
This article was previously published under Q282316 Advanced: Requires expert coding, interoperability, and multiuser skills.
This article applies only to a Microsoft Access database (.mdb).
SYMPTOMS
After you have synchronized one member of a replica set with another, some of the data in the two databases may not match as expected.
CAUSE
This behavior can occur if the data in a field is being edited while changes to the same field in the same record are being communicated by synchronization.
RESOLUTION
To prevent this issue from occurring, make sure that no one is editing records in a table when you run synchronization.
Another way to prevent this behavior is to upsize the database from a Microsoft Access database (.mdb) to Microsoft SQL Server or a Microsoft Access project (.adp), and then use SQL Server's replication functionality. For more information about upsizing your database, click Microsoft Access Help on the
Help menu, type upsizing in the Office Assistant or
the Answer Wizard, and then click Search to view the topics
returned. For additional information about upsizing your database, click the article number below
to view the article in the Microsoft Knowledge Base:
294407 ACC2002: "Access 2002 Upsizing Tools" White Paper Available in Download Center
For additional information about replication in Microsoft SQL Server 2000, browse to the following Microsoft Web site:
To resolve this issue when it occurs, make note of any write conflicts you get when synchronizing. After synchronization is complete, check the records that had the write conflict. If the data is not correct, modify the record, and then synchronize again. This will send the changes and cause a conflict that will have to be resolved.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. REFERENCESFor more information about replicated databases, click Microsoft Access Help on the
Help menu, type replication in the Office Assistant or
the Answer Wizard, and then click Search to view the topics
returned.
For more information about record locking, click Microsoft Access Help on the
Help menu, type record locking in the Office Assistant or
the Answer Wizard, and then click Search to view the topics
returned.
Modification Type: | Major | Last Reviewed: | 11/5/2003 |
---|
Keywords: | kbbug KB282316 |
---|
|