ACC97: Error Message: "Can't Find the Dynamic-Link Library (DLL) Mso97rt" (282285)
The information in this article applies to:
This article was previously published under Q282285 Novice: Requires knowledge of the user interface on single-user computers.
SYMPTOMS
Under certain circumstances, when you start the retail version of Microsoft Access 97 after you have previously installed and uninstalled the run-time version of Microsoft Access, you may receive the following error message:
Can't find the dynamic-link library (DLL) Mso97rt.
You can't use the /runtime command-line switch unless you have installed Microsoft Office 97 Developer Edition Tools.
CAUSE
When you tried to install the full version of Access 97, the regular retail license was not properly written to the registry. Because the run-time license from the previous Access installation is still present in the registry, Access thinks it is supposed to start in run-time mode and searches for the file Mso97rt.dll, which was previously uninstalled and is no longer available.
RESOLUTION
The steps to properly install the retail license for Microsoft Access are documented in the following article:
141373 ACC: 'There Is No License' Error Starting Microsoft Access
Although the error message in Q141373 is different, the underlying problem and resolutions are the same. If you had not previously installed and uninstalled a run-time version of Access, you would be getting the "No License" error specified in Q141373 instead of the Mso97rt error.
Modification Type: | Major | Last Reviewed: | 9/27/2003 |
---|
Keywords: | kberrmsg kbprb KB282285 |
---|
|