Pressing CTRL+ALT+DELETE and Then Cancel Appears to Disconnect the Session (281988)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

This article was previously published under Q281988

SYMPTOMS

While you are using Terminal Services Advanced Client in Full-Screen mode, if you use the CTRL+ALT+DELETE key combination to lock the session, and then you click Cancel, this appears to disconnect the Terminal Services session.

CAUSE

This problem is caused by the behavior of Terminal Services Advanced Client, which is an ActiveX control. The control becomes independent of the Microsoft Internet Explorer shell during full-screen activation. In some scenarios (such as ALT+TAB, CTRL+ALT+DELETE, or in a multiple-monitor environment), if you switch to the Internet Explorer window that is hosting the control, it appears to host a blank control.

RESOLUTION

To resolve this problem, you can restore the session by clicking the Full-Screen icon at the bottom of the screen, or press ALT+TAB to switch back to the Terminal Services session. When you press ALT+TAB, you can switch between active programs.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Here is sample scenario of when this problem may occur:
  1. Start a Terminal Services Advanced Client session.
  2. Press CTRL+ALT+BREAK to put the session in Full-Screen mode.
  3. Press CTRL+ALT+END to lock the session.
  4. Press CTRL+ALT+DELETE.
  5. Click Cancel.
  6. The Internet Explorer page appears blank.
  7. The session appears to be disconnected.
In this scenario, the session is not actually lost. You can restore it by using the methods described in the "Resolution" section in this article.

For more information about how to script the Terminal Services Advanced Client, refer to the article in the following MSDN Web site:

Modification Type:MajorLast Reviewed:4/18/2006
Keywords:kbenv kbprb kbsetup KB281988