The computer stops responding (hangs) during setup when you install updates or when you add new hardware (281967)



The information in this article applies to:

  • Flight Simulator X Deluxe
  • Flight Simulator X Standard
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: The Titans
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft DirectX Software Development Kit 8.0a
  • Microsoft Flight Simulator 2004 - Century of Flight
  • Microsoft Flight Simulator 2002
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Freelancer
  • Microsoft Greetings 2002 1.0
  • Microsoft Halo: Combat Evolved
  • Microsoft Impossible Creatures
  • Microsoft IntelliMouse Explorer
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition
  • Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 1
  • Microsoft Links 2003
  • Microsoft Links 2003 Championship Edition
  • Microsoft MechWarrior 4: Mercenaries
  • Microsoft Money 2004 Deluxe
  • Microsoft Money 2004 Premium
  • Microsoft Money 2004 Small Business
  • Microsoft Money 2004 Standard
  • Microsoft Money 2003 Deluxe
  • Microsoft Money 2003 Standard
  • Microsoft Money 2003 Suite
  • Microsoft Money 2002
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Premium
  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Photo 2002 1.0
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft SideWinder Precision Racing Wheel
  • Microsoft Train Simulator
  • Microsoft Windows Millennium Edition
  • Microsoft Zoo Tycoon
  • Microsoft Zoo Tycoon: Dinosaur Digs Expansion Pack
  • Microsoft Zoo Tycoon: Marine Mania Expansion Pack

This article was previously published under Q281967

SYMPTOMS

You may experience any of the following symptoms:
  • When you try to upgrade a computer to Microsoft Windows Millennium Edition, the computer may stop responding (hang) during setup.
  • When you try to install a Microsoft Internet Explorer 5.5 service pack or a Microsoft Internet Explorer 6, the computer may stop responding when Setup is 70 percent complete, or you may receive the following error message:
    Error 52: Setup could not finish opening a file on your destination disc.
  • When you try to add new hardware, the Add New Hardware wizard may stop responding. Or, when you start the computer after you add new hardware, the computer may stop responding when Plug and Play detects that a new device is installed or attached to the computer.
  • When you install critical updates from the Microsoft Windows Update Web site, the computer may stop responding.
  • When you install an update to the Microsoft virtual machine (Microsoft VM), the computer may stop responding.
  • When you install Microsoft DirectX 8.0 or a later version, the computer may stop responding.

CAUSE

This problem may occur if too many device driver INF files (Oem*.inf) exist in the Windows\Inf folder. The Oem*.inf files can be created by Windows Update, Internet Explorer Setup, and any other program that uses the Microsoft Setup APIs if a disk utility program currently has a volume lock on the drive. Microsoft programs and third-party utility programs such as ScanDisk, defragment programs, and other system utilities must obtain a volume lock on the drive to control access by other processes to the volume.

RESOLUTION

To resolve this problem, apply the fix that is described in the following Microsoft Knowledge Base article:

301540 CreateFile improperly returns ERROR_ALREADY_EXISTS if the Drive is locked and the file did not exist

To work around this issue, delete all the Oem*.inf files in the Windows\Inf folder whose size is 0 kilobytes (KB).

To delete all the 0 KB files, follow these steps:
  1. Set Microsoft Windows to show all files. To do this, open Microsoft Windows Explorer, click Folder Options on the Tools menu, click the View tab, click Show hidden files and folders, and then click OK.
  2. Click Start, point to Search, and then click For Files or Folders.
  3. In the Search for files or folders named box, type oem*.inf.
  4. Verify that the Look in box shows the Inf folder. Typically, the path of this folder is C:\Windows\Inf.
  5. Click Search Now.
  6. In the Search Results window, click the header of the Size column to sort the files by size. If you cannot see the Size column, maximize the Search Results window.
  7. Select all the files whose size is larger than 0 KB to a temporary location. To do this, follow these steps:
    1. In the Search Results window, click the first file that has a size larger than 0 KB, and then press and hold down the SHIFT key as you click the last file that has a size larger than 0 KB.
    2. On the Edit menu, click Copy.
    3. Right-click an empty area on the desktop, point to New, and then click Folder.
    4. Type an appropriate name for the folder (for example, type Oeminf), and then press ENTER.
    5. Right-click the new folder, and then click Paste.
  8. Remove the 0 KB .inf files. To do this, follow these steps:
    1. Click Start, point to Programs, point to Accessories, and then click MS-DOS Prompt.
    2. At the command prompt, type the following lines, pressing ENTER after you type each line:

      cd \windows\inf
      del oem*.inf
      exit

      Note This process can take several minutes, depending on the speed of the computer and on the number of files that are in the Inf folder. On older computers that have lots of files (40,000 or more), this process can take up to an hour to finish.
  9. Exit the command prompt by typing exit, and then pressing ENTER.
  10. Open the Oeminf folder that was created on the desktop, click Select All on the Edit menu, and then click Copy on the Edit menu.
  11. On the desktop, double-click My Computer.
  12. Locate and then double-click the Inf folder. Typically, the path of this folder is C:\Windows\Inf.
  13. On the Edit menu, click Paste.
  14. Verify that the files from the Oeminf folder have been successfully copied to the Inf folder by comparing the two folders.
  15. Close all the windows that are open.
  16. Disable all the disk utility programs, and then install the Windows Millennium Edition updates.

Modification Type:MajorLast Reviewed:9/27/2006
Keywords:kberrmsg kbprb kbsetup KB281967