USB Device Cannot Receive Data (281946)
The information in this article applies to:
- Microsoft Windows 98 Second Edition
- Microsoft Windows Millennium Edition
This article was previously published under Q281946
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware: SYMPTOMS
Specific combinations of Universal Serial Bus (USB) controllers and USB device drivers may result in the USB device being able to send, but not receive any data.
Refer to the MORE INFORMATION section for a list of configurations known to manifest this problem.
CAUSE
This problem can occur if a USB device driver attempts to use a bulk data feature known as "double-buffering".
Double-buffering is not a hardware feature; nor is it stipulated in the USB 1.x and 2.x specifications. It is a software technique that failed to improve data throughput, and was therefore abandoned. The feature is undocumented, and unsupported by Microsoft. Attempted use of this feature may expose data latency issues in device driver IRP processing.
RESOLUTION
To resolve this behavior if you are experiencing this problem in conjunction with the Intel AnyPoint Phoneline Home Network Network adapter (10 Mbps USB model), obtain and install the latest upgrade to version 2.00.01 or later of the AnyPoint Connectivity Suite which is available by contacting Intel Technical Support.
If you have any other USB device that displays the behavior that is described in the SYPTOMS section of this article, contact your USB device vendor to verify that your device drivers attempt to use double-buffering, and to obtain new drivers if this is the case.
STATUS
This behavior is by design. Double-buffering is not a part of the supported USB specifications, and is undocumented, as well as unsupported by Microsoft.
Modification Type: | Major | Last Reviewed: | 8/8/2006 |
---|
Keywords: | kb3rdparty kbHardware kbnofix kbprb KB281946 |
---|
|