OL97: Link to Item in Public Folder Does Not Work (281938)
The information in this article applies to:
This article was previously published under Q281938 SYMPTOMS
You use the Outlook protocol to create a link to an item in a public folder. The link uses the EntryID property of the item, but when someone clicks the link, they receive the following error message:
Unable to display the selected folder or item.
CAUSE
For performance reasons, Outlook does not initialize public folders until they are selected in the Outlook user interface. This prevents the link from working, because the Outlook protocol does not force Outlook to initialize the public folders.
WORKAROUND
Use one of the following methods to work around this problem:
Method 1
Create a solution that uses the Outlook object model to reference a public folder when Outlooks starts. The object model forces Outlook to initialize the public folders and subsequently, links based on Entry IDs will work. For example, you can create a COM add-in that references the Public Folders folder every time Outlook starts.
Method 2
If possible, use the Outlook object model to launch the item instead of using the Outlook protocol.
MORE INFORMATION
When a link that is using the Outlook protocol is activated, Outlook searches for the Entry ID in each store that it considers open, not each store that you can see in the list of folders.
REFERENCESFor additional information about creating solutions with Microsoft Outlook, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
166368 OL97: Resources for Custom Forms and Programming
170783 OL97: Questions About Customizing or Programming Outlook
Modification Type: | Minor | Last Reviewed: | 3/9/2005 |
---|
Keywords: | kberrmsg kbprb kbSCRAPKeep KB281938 |
---|
|