Computer Suspends After Resuming with Keyboard Power Key (281921)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q281921
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

Your computer may spontaneously suspend immediately after you cause it to resume by pressing the power button on the keyboard. This problem is likely to occur only if you suspended your computer from the Start menu, and is not likely to occur if you suspended the computer by using the keyboard power button.

CAUSE

When you press a sleep button on keyboard, a VK_SLEEP keycode message is sent to Power Manager (Vpowerd.vxd) by the Windows kernel. Vpowerd typically ignores messages while it is busy with a resume. However, there is a small time window in which Vpowerd can react to messages; if a VK_SLEEP message arrives during this time, the message is treated as a legal sleep request, and the computer is suspended.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time     Version    Size     File name
   -----------------------------------------------------
   12/20/2000  05:14pm  4.90.3002  120,845  Configmg.vxd
   12/22/2000  03:06pm  4.90.3004   50,223  Vpowerd.vxd
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

295413 General Information About Windows Millennium Edition Hotfixes


Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kbfix kbHardware kbprb kbQFE KB281921