PIP: Missing Contents of Left Pane, Missing Graphics in Project, or "Invalid Page Fault" Error Message (281915)



The information in this article applies to:

  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Photo 2001
  • Microsoft Picture It! Photo 2002 1.0
  • Microsoft Picture It! Photo Premium 2001
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Picture It! Publishing 2001 Silver

This article was previously published under Q281915

SYMPTOMS

When you run any of the programs listed at the beginning of this article, you may experience one or more of the following symptoms:
  • The contents of the left pane may be missing.
  • Project screens may not be rendered properly, and project graphics may be missing.
  • You may receive an error message similar to one of the following:
    • filename caused an invalid page fault in module gdi.exe.
      filename caused an invalid page fault in module kernel32.dll.

CAUSE

This behavior may occur if one of the following is true:
  • One or more components of Microsoft Internet Explorer are corrupt.
  • A device that is installed in your computer uses the same interrupt request (IRQ) as your Peripheral Component Interconnect (PCI) video adapter.
  • You have too many fonts installed on the system.
  • A "Font Manager" type program is installed on your computer, and it is blocking the installation of the Picture It! fonts.

RESOLUTION

To resolve this issue, you can do one of the following:

Method 1

Run the Internet Explorer repair utility.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, and then click Control Panel.
  2. Double-click Add or Remove Programs.
  3. In the left pane, click Change or Remove Programs.
  4. Click Microsoft Internet Explorer, and then click Change or Change/Remove.
  5. When you receive a prompt, click Repair.
  6. Follow the on-screen instructions to complete the repair process.
If the problem is not resolved, or if Microsoft Internet Explorer is not in the list of programs, use method 2.

Method 2

Install the latest driver available for your video adapter.

For information about how to contact the manufacturer of your video adapter, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

If you install the latest driver, and the issue continues to occur, follow this method:

Reduce Hardware Acceleration

You may be able to work around this issue by changing the hardware acceleration setting for your video adapter. To change the hardware acceleration setting, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Performance tab, click Graphics.
  4. Move the Hardware Acceleration slider to None.
  5. Click OK, and then click Close.
  6. Click Yes to restart the computer.

Method 3

Contact your hardware manufacturer to inquire about how to disable or move the device that shares the IRQ channel with the video adapter.

For information about how to contact the manufacturer of the device, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Method 4

Reduce the number of fonts on the system to 200 or fewer.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Method 5

Copy all the fonts from the drive:\PIP\Fonts folder into the c:\Windows\Fonts folder, where drive is the drive in which you put the Picture It! CD-ROM.

NOTE: You may need to click OK to replace fonts during this process.

MORE INFORMATION

This behavior is common to all PCI display adapters, but does not apply to Industry Standard Architecture (ISA) or VESA Local Bus (VLB) display adapters.

PCI devices can share IRQs. This behavior is in the PCI specification and it is supported in Microsoft Windows. PCI devices are configured in the BIOS settings for the computer during the Power-On Self Test (POST) before the operating system is loaded. Windows does not configure PCI devices - it uses the settings reported by the BIOS.

To determine if your video adapter shares an IRQ channel with another device, use the appropriate method for your version of Microsoft Windows.

Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me)

  1. Click Start, and then click Run.
  2. In the Open box, type msinfo32, and then click OK.
  3. In the left pane, click the plus sign (+) next to Hardware Resources to expand the branch.
  4. Under the Hardware Resources branch, click Conflicts/Sharing.
  5. Under the Shared Resource column, note the IRQ channel for your video adapter, and then note any other devices that use the same IRQ channel.
  6. Close the Microsoft System Information tool.

Microsoft Windows 95

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Device Manager tab.
  4. Select View Devices by Type.
  5. Click Computer, and then click Properties.
  6. On the View Resources tab, click Interrupt request (IRQ).
  7. Note the IRQ channel for your video video adapter, and then note any other devices that use the same IRQ channel.
  8. Click OK, and then click OK again.
  9. Close Control Panel.

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

195708 List of Default Fonts Included in Windows 98


Modification Type:MinorLast Reviewed:1/24/2005
Keywords:kbdisplay kbprb KB281915