Error Message Appears When You Send E-mail over the Internet from POP or IMAP Program (281704)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q281704

SYMPTOMS

On a computer that runs Windows 2000, if you send a message out over the Internet by using a program that uses Post Office Protocol (POP) or Internet Message Access Protocol (IMAP), you may receive the following error message:
Unable to open the message for delivery
The following event may appear many times in Event Viewer:
Smtpsvc N/A CPDCPUBC01 Message delivery to the remote domain 'mdcplus.com' failed. The error message is 'Unable to open the message for delivery.'

CAUSE

This behavior can occur if there are multiple e-mail recipients on an outbound message, and the RCPT TO command for a recipient's address does not work and returns the status code 552. Code 552 means that there are too many recipients. Simple Mail Transfer Protocol (SMTP) sends the message for the recipients where delivery is successful. If the mail is queued for delivery, the MAIL FROM command runs again, and picks up on the RCPT TO command for the recipient addresses where delivery does not succeed.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time    Version         Size     File name
   -------------------------------------------------------
   5/31/2001   03:31p  5.0.2195.3649   320,272  Aqueue.dll
   5/31/2001   03:31p  5.0.2195.3649    66,832  Mailmsg.dll
   5/31/2001   03:31p  5.0.2195.3649    38,160  Ntfsdrv.dll
   5/31/2001   03:32p  5.0.2195.3651   434,448  Smtpsvc.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:10/12/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE kbWin2000PreSP3Fix KB281704