Remote Assistance Tool Does Not Notify You If You Enter an Invalid E-mail Address (281669)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q281669

SYMPTOMS

When you use the Remote Assistance tool, and you send a Remote Assistance invitation, if you enter an invalid e-mail address for the helper address, and then send the invitation, the Remote Assistance tool does not notify you that you used an invalid e-mail address.

CAUSE

This issue occurs because the Remote Assistance tool is not able to confirm that the e-mail addresses are valid or if the help request message was received. The Remote Assistance tool passes the e-mail address to your default mail client which tries to send the message. If the address is rejected by your mail client, you may receive an error from your e-mail program.

RESOLUTION

To work around this issue, confirm that the recipient and the sender e-mail addresses that you entered are correct and valid. Ask the recipient to notify you when the help request message is received.

STATUS

This behavior is by design.

MORE INFORMATION

When you send a message with an incorrect address, the following two kinds of issues may occur:
  • Synchronous: Errors that are detected and returned when you request the message to be sent.
  • Asynchronous: Errors that occur after MAPI has accepted the request to send the message.
Most errors that occur are asynchronous, except for basic parameters validation errors. A message might not be sent for a number of reasons, including network failure, or because the recipient e-mail system rejected the message. Because you are not notified of any failures, you can only be sure that the message was successfully sent if the recipient (or their e-mail system) acknowledges that the message was received.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbprb KB281669