Setup Appears to Stop Responding at the Registering Components Screen During an Unattended Installation (281653)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q281653

SYMPTOMS

In an unattended installation, if a large amount of files are being copied with the /copydir or /copysource switch, Setup may appear to stop responding, where the time to completion does not progress for an extended period of time.

CAUSE

This problem occurs because Setup checks each file for a signature, and logs an entry in the %SystemRoot%\Setupapi.log file if the file is not signed. In cases where the installation uses this feature to copy a large amount of files, impact of this operation may be significant.

RESOLUTION

To work around this problem, use the $oem$ folder structure to copy files during the installation.

For more information about $oem$ usage, read the Deploy.doc that is located on the Windows XP CD-ROM in the following location:

\Support\Tools\Deploy.cab

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbenv kbprb kbsetup KB281653