IIS Problems After Applying a Security Patch (281402)



The information in this article applies to:

  • Microsoft Internet Information Server 4.0
  • Microsoft Internet Information Services 5.0

This article was previously published under Q281402
We strongly recommend that all users upgrade to Microsoft Internet Information Services (IIS) version 6.0 running on Microsoft Windows Server 2003. IIS 6.0 significantly increases Web infrastructure security. For more information about IIS security-related topics, visit the following Microsoft Web site:

SYMPTOMS

Some systems encounter Internet Information Services (IIS) failures, logon problems, and Dr. Watson exceptions after security patches are applied.

CAUSE

The patch may have been installed before all components were at the required service pack level. All components need to be at the service pack level that is described in the Microsoft Knowledge Base articles that are associated with the service packs.

NOTE: Even if you have previously applied Service Pack 5 or Service Pack 6a, it is possible to have some older dynamic-link libraries (DLLs) if you have installed other software that has replaced them.

RESOLUTION

If you have not yet installed the security patch, apply the service pack before you install the patch.

If you have already installed the patch and are now experiencing IIS, File Transfer Protocol (FTP), or similar problems, follow these steps to resolve the problem:
  1. Type prmcan4i -x at a command prompt to extract the files within the hotfix executable file.

    Type hotfix -y /m at a command prompt to unistall the hotfix.

    Reapply the service pack and restart your computer.

    Type prmcan4i at a command prompt to reinstall the hotfix.

    Restart your computer.
  2. Type hotfix -y /m at a command prompt to unistall the hotfix.

    Reapply the service pack and restart your computer.

    Type prmcan4i at a command prompt to reinstall the hotfix.

    Restart your computer.
  3. Reapply the service pack and restart your computer.

    Type prmcan4i at a command prompt to reinstall the hotfix.

    Restart your computer.
  4. Type prmcan4i at a command prompt to reinstall the hotfix.

    Restart your computer.
  5. Restart your computer.

MORE INFORMATION

Refer to the Knowledge Base article that is associated with the security update for more information. To determine which Knowledge Base article is associated with the security update, read the security bulletin that is associated with the patch.

For more information, see the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/23/2005
Keywords:kbpending kbprb KB281402