Images May Be Missing on Search Results Pages Using POST Redirect (281197)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 2000 SP 1
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 1

This article was previously published under Q281197

SYMPTOMS

When you are retrieving results from Internet search pages, some banner images or other elements of the results page may not be displayed. Instead of an image, a white box with a red X is displayed, indicating that the image is missing.

CAUSE

This issue can occur if the following conditions exist:
  • An external HTTP namespace handler is installed.
  • A POST operation that returns a Uniform Resource Locator (URL) in the form of an "HTTP 302 redirect" is used.
With an external HTTP namespace handler, Internet Explorer does not properly retrieve the "302 redirect" URLs that are returned from the POST operation. If the redirected URL is an image, the image is not displayed in Internet Explorer.

A third-party program such as RealNetworks RealDownload may be registered as an external HTTP namespace handler when it is installed.

RESOLUTION

To resolve this problem, obtain the latest service pack for Internet Explorer 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

276369 How to Obtain the Latest Service Pack for Internet Explorer 5.5

WORKAROUND

After the results page is displayed, refresh the page by clicking Refresh on the toolbar, or by clicking Refresh on the View menu to retrieve the redirected URL and display the missing image.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Internet Explorer 5.5 Service Pack 2.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/26/2003
Keywords:kb3rdparty kbprb KB281197