MechWarrior 4: Errors, Black Screen or Computer Stops Responding (281124)



The information in this article applies to:

  • Microsoft MechWarrior 4: Vengeance 4.0
  • Microsoft MechWarrior 4: Black Knight
  • Microsoft MechWarrior 4: Mercenaries

This article was previously published under Q281124

SYMPTOMS

When you attempt to start any of the products listed above, the game screen may turn black and the computer stops responding, or you may receive one of the following error messages:
Your hardware or drivers setup are not compatible with MechWarrior 4. Please contact your hardware manufacturer for more information, and see the Readme.rtf for known issues.
EXCEPTION : Access violation in AUTOCONFIG!
EXCEPTION : Attempt to read from address 0x004CDA74 in AUTOCONFIG!

CAUSE

This behavior may occur if one of the following conditions is true:
  • Your computer does not meet the minimum 3-D hardware requirements required to play the game.
  • The video drivers on your computer are damaged or outdated.
  • The Direct3D or DirectDraw feature is turned off.
  • A video adapter that is based on the 3Dfx Voodoo2 chip set is installed in your computer.
  • A Diamond Monster 3D II video adapter is installed in your computer.
  • Your desktop color is set to 24-bit color.

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented.

Make Sure That Your Video Adapter Meets Minimum Requirements

For all boxed games, see the minimum system requirements that you need to play the game, which are listed on the box.

Use the DirectX Diagnostic Tool to Determine How Much Video Memory Is Available

To check minimum system requirements:
  1. On the Windows task bar, click Start, and then click Run.
  2. In the Open box, type dxdiag, and then click OK.
  3. In the DirectX Diagnostic Tool dialog box, click the Display or Display 1 tab.
  4. In the Device field, note the amount of video memory on the Approx. Total Memory line, and then click Exit.
NOTE: The newer versions of Microsoft DirectX automatically install the DirectX Diagnostic Tool.

Adjust Display Settings

Many newer Microsoft games require a video adapter and monitor that can run a resolution of at least 800 x 600 at high color (16 bit). Set your Windows display resolution to 800 x 600 at high color (16 bit), and then test the game.
Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Display.
  3. Click the Settings tab.
  4. Move the Desktop Area, Screen Area, or Screen resolution slider to the 800 x 600 pixels setting. (The specific slider you see depends on what operating system you have.)
  5. In the Color Palette or Colors box, click 16-bit high color or Medium (16 bit).
  6. Click OK, click OK again, and then click Yes to accept the settings.

    NOTE: This may reduce your desktop area to a lower resolution. After you change your video resolution, you may have to adjust your monitor settings so that your screen is displayed correctly. See your monitor documentation for more information.
  7. Quit the game, and then start the game. If the problem continues to occur, repeat steps 1-4, but change to High Color 32-bit.
NOTE: If you know what resolution your game is set to run at, you may also try setting your Windows display settings to the same resolution as the game.

Turn on the Direct3D and DirectDraw Features

To turn on the Direct3D and DirectDraw features, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type dxdiag, and then click OK.
  3. Click the Display tab.
  4. Under DirectX Features, verify that the DirectDraw Acceleration and the Direct3D Acceleration lines are set to Enabled.

    If either of these lines contain a Disabled status, click the Enable button to the right of that line.
  5. If multiple display adapters are installed in your computer, repeat steps 3 and 4 for each Display tab in the DirectX Diagnostic Tool.
  6. Click Exit to close the DirectX Diagnostic Tool.
Test to see if the issue is resolved.

If the issue continues to occur, continue with the next method.

Reduce Graphics Hardware Acceleration

To reduce graphics hardware acceleration:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab, and then click Graphics.
  4. Move the Hardware Acceleration slider until it is one notch to the right of None (the basic acceleration setting).
  5. Click OK, and then click Close.
  6. When you are prompted to restart your computer, click Yes.
Test to see if the issue is resolved

NOTE: In some cases, the game may not run until you move the slider to a higher setting. If the issue continues to occur, repeat Step 4 and increase the graphics hardware acceleration.

NOTE: If your game runs with video acceleration turned down, it may indicate that you must update your video driver or it may indicate that your video adapter cannot run your game at full acceleration.

If the issue continues to occur, continue with the next method.

Configure Hardware Acceleration to Use the Full Setting

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab, and then click Graphics.
  4. Move the Hardware Acceleration slider all the way to the right (the Full position).
  5. Click OK, and then click Close.
  6. When you are prompted to restart your computer, click Yes.
Test to see if the issue is resolved.

Update Your Video Driver

Contact the manufacturer of your video adapter to inquire about how to obtain and install the latest version of the video driver for your video adapter. For additional information about how to contact your hardware manufacturer, click the article numbers below to view the articles in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

To identify the manufacturer and model of your video adapter, follow these steps:
  1. On the Start menu, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. If you have a Windows 95- or Windows 98-based computer, click the Device Manager tab.

    If you are using a Windows 2000-based computer, click the Hardware tab, and then click Device Manager.
  4. Expand (click the PLUS SIGN next to) the Display adapters branch.
  5. Under the Display adapters branch, note the manufacturer and model of your video adapter, and then click OK.
  6. Close all open windows.

Upgrade Your Video Adapter

Use the DirectX Diagnostic Tool to determine the amount of video memory installed on your video adapter. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type the following line (including the quotation marks), and then click OK:

    "drive:\program files\directx\setup\dxdiag.exe"

    where <drive> is the drive letter of the hard disk on which Microsoft Windows is installed.
  3. Click the Display or Display 1 tab.
  4. In the Device section, note the amount of video memory on the Approx. Total Memory line. Click Exit.
At least 8 megabytes (MB) of video memory should be installed on your video adapter.

If less than 8 MB of video memory is installed on your video adapter, install additional video memory on your video adapter, or install a video adapter with more video memory.

If the issue continues to occur, continue with the next method.

Install Microsoft DirectX

Download and install the latest version of DirectX from the following Microsoft Web site: For additional information about how to obtain and install the latest version of DirectX, click the article number below to view the article in the Microsoft Knowledge Base:

179113 How to Download and Install DirectX



If the issue continues to occur, contact your computer or video adapter manufacturer to inquire about how to obtain and install the latest version of the video driver for your video adapter.
For information about how to contact your hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

MORE INFORMATION

For more information on system requirements for MechWarrior 4: Vengeance, please see the following article in the Microsoft Knowledge Base:

279362 MechWarrior 4: Vengeance: Minimum System Requirements


Modification Type:MinorLast Reviewed:6/17/2005
Keywords:kbConfig kbHardware kbdisplay kbenv kberrmsg kbprb KB281124