(CW) How to Replace Names in a Contact E-mail Address Field (280460)
The information in this article applies to:
- Microsoft Outlook 2000
- Microsoft Outlook 98
This article was previously published under Q280460 NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".
SYMPTOMS
Contact items may not show an e-mail address in the E-mail Address field, but may display a resolved (underlined) name in the E-mail Address field of the contact.
NOTE: This procedure only applies to the Contact item display name. It does not change the way your address book shows the display name.
CAUSE
This behavior occurs because the resolved name for this contact was previously resolved to an e-mail address in the source application. This information is the display name that is in the E-mail Properties dialog box.
This behavior is by design.
RESOLUTION
Use one of the following methods to resolve this behavior:
Manually Replace the Resolved Name with the E-mail Address
You can manually change the e-mail display name for each contact. To do this:
- Double-click the resolved (underlined) name in the E-mail field of the contact.
- In the E-mail Properties dialog box, replace the display name information with the e-mail address.
- Click OK, and then click Save and Close the Contact.
Change All E-mail Display Names By Using the Export and Import Process
You can export your contacts to a Comma Separated Values (.csv) file. After you export your contacts, you can remove the e-mail display name from the Export Field Map, re-import the data into Outlook, and select to replace all duplicate items. This method is useful if you have a large number of contacts. WARNING: If you have any attachments, shortcuts or other embedded items in the original contacts, you will loose them when you inport the new data back into Outlook. Move those contacts to another Contacts folder before you begin this process, to preserve the attachments, shortcuts or other embedded items. How to Export and Import Contacts By Using a .csv FileStep 1: How to Export your Data from Outlook to a .csv File- Install the Outlook 98 Field Mapping Patch. The instructions for download and installation can be found by clicking the link in the References section of this article.
- On the File menu, click Import and Export.
- Click Export to a file, and then click Next.
- Click Comma Separated Values (Windows), and then click Next.
- Click the Contacts folder, and then click Next.
- Click the Browse button, select a name and location to save your exported file, click OK, and then click Next.
- Click Map Custom Fields to modify the field mapping.
- In the Map Custom Fields dialog box, locate and click to remove the Email Display Name, Email Display Name 2 and Email Display Name 3 fields in the To Comma Separated Values (Windows) column.
- Click OK, and then click Finish.
Step 2: How to Import Your Data Back to Outlook from the Modified .csv File- Click the File menu, and then click Import and then Export.
- Click Import from another program or file, and then click Next.
- Click Comma Separated Values (Windows), and then click Next.
- Click the Browse button, select the file that you created from the location where it was saved, and then click OK.
- Click to select the Replace Duplicates with items imported check box, and then click Next.
- Click the Contacts folder, and then click Next.
- Click Finish.
The contacts will be imported with the e-mail alias in the E-mail Address field.
REFERENCESFor additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
182728 OL98: Options For Custom Field Mapping When Importing Items
Modification Type: | Major | Last Reviewed: | 2/5/2004 |
---|
Keywords: | kbprb KB280460 |
---|
|