Health Monitor May Be Unable to Send E-Mail via Local Exchange SMTP Server (280043)



The information in this article applies to:

  • Microsoft BackOffice Server 2000
  • Microsoft Small Business Server 2000

This article was previously published under Q280043

SYMPTOMS

When you configure the Health Monitor snap-in to send e-mail notifications and it is set to process e-mail notifications by means of the local Microsoft Exchange 2000-based server, you may receive the following error message:
Action Failed: 0x8004100a
If you attempt to use Microsoft Outlook Express from the server to process messages by means of the locally installed Exchange 2000-based server, you may receive the following error message:
550 5.7.1 Unable to relay for user@yourdomain.com

CAUSE

This behavior can occur because the Simple Mail Transfer Protocol (SMTP) virtual server relay settings that run on an Exchange 2000-based server are not configured correctly. This behavior may also occur if the server is multi-homed and the external interface is listed first in the binding order.

RESOLUTION

There are multiple ways to resolve this behavior, each depending upon the binding order, relay settings, and the method being used to specify the relaying server. To simplify the resolution process, it is preferable to configure the SMTP server in a way that applies to all situations.

To resolve this behavior, perform the following steps, assuming that the server is either multi-homed or has a single network adapter:

Verify the Binding Order

  1. From the server, right-click My Network Places, and then click Properties.
  2. In the Networks and Dial-up Connections window, click the Advanced menu, and then click Advanced Settings.
  3. Under the Adapters and Bindings tab, select your internal network interface, and then click the Up Arrow button on the right side to move the internal interface selection to the top of the list.
  4. If Remote Access Connections is listed, ensure that it is at the bottom of the list.
  5. Click OK to apply the changes.

Verify the Relay Settings for the Exchange SMTP Virtual Server

NOTE: This procedure can configure the local SMTP virtual server to enable only internal client computers and the server to process e-mail notifications. External clients are only able to process e-mail notifications with Exchange Server if they authenticate by means of SMTP.
  1. From the server, click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  2. On the right pane, expand Servers. Then expand your server and expand Protocols.
  3. Select and expand SMTP. Right-click Default SMTP Virtual Server, and then click Properties.

    NOTE: By default, there is only one SMTP virtual server. If you have multiple virtual servers listed, these steps may not apply to your configuration.
  4. Click the Access tab and click Relay.
  5. Verify that the Only the list below option is selected. Verify that your external Internet Protocol (IP) address is specified. If the external IP address is not specified, click Add. Click Single Computer and type in the IP address of the external interface. To add the entry, click OK.
  6. Verify that your local subnet is also included in the list. If it is not listed, click Add, and then click Group of Computers. Type the internal IP address of the server (for example, 192.168.16.2), and then type the subnet mask of the internal interface (for example, 255.255.255.0). Click OK to add the entry, and then click OK again to apply the changes.
  7. Close System Manager.
  8. Close any instances of Health Monitor, including the Small Business Server Administration Console.
  9. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  10. On the right pane, right-click Windows Management Instrumentation.
  11. Click Restart to stop and restart the service.
  12. When the service has started, close the Services Management Console.
With these settings in place, Health Monitor and any other SMTP client on the server should be able to process messages by means of the local SMTP server. When you specify the SMTP server for the SMTP programs on the server, you should use the NetBIOS name of the server or the internal IP address.

MORE INFORMATION

When you have run the Internet Connection Wizard (ICW) and the Full Time Connection option has been selected, the preceding relay settings are configured. The ICW uses the internal IP address and internal subnet mask to specify the group of computers that can enable relay access. It also adds the external IP address of the server to the list of permitted computers.

The main reason to add the external IP address is to include the possibility of a program on the server binding to the external IP. If a program binds to the external IP and the program is configured to relay by means of the local SMTP server, the SMTP server identifies the connection as originating from the external IP address. Therefore, if the external IP address is not listed as "Allowed", the SMTP server denies relaying.

The binding order is also important. If the external network adaptor is listed first in the binding order, any attempts to resolve the server name returns the external IP address. If a program attempts to connect to the SMTP server by name and the external network adaptor is first in the binding order, depending upon the program, it may bind to the external interface. Therefore, when you attempt to relay by means of the SMTP server, the SMTP server identifies the connection as originating from the external IP.

Modification Type:MinorLast Reviewed:1/25/2006
Keywords:kbprb KB280043