WMI Windows 95 Clients Not Reporting DHCP Information Correctly (279873)



The information in this article applies to:

  • Microsoft Windows Management Instrumentation 1.5, when used with:
    • the operating system: Microsoft Windows 95

This article was previously published under Q279873

SYMPTOMS

After you install the Microsoft Windows Socket 2 Update on a computer that is running Windows 95 OEM Service Release 2 (OSR2), the Windows Management Instrumentation (WMI) Win32_NetworkAdapterConfiguration class may not return valid Dynamic Host Configuration Protocol (DHCP) information.

CAUSE

This problem occurs because you change the structure of the DHCP information that the following registry key contains when you install the Windows Socket 2 Update on a computer that is running Windows 95 OSR2 (4.00.950 B):

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\DHCP

The original WMI Win32 provider is not designed to process this changed DHCP information structure.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time       Size      File name      Version          Operating System
   ----------------------------------------------------------------------------------
   12/19/2000   11:56:08   778,319   Cimwin32.dll   1.50.1085.0042   Windows 95 OSR2
				

Using the Hotfix Installer

NOTE: You can use the following method only for Intel-based computers:
  1. Copy the hotfix program (Q279873.exe) to a local folder on your computer or to a shared drive on your network.
  2. Start the Q279873.exe program and follow the instructions.
  3. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

This problem does not occur in Microsoft Windows 98, Microsoft Windows Millennium Edition (Me), Microsoft Windows NT, or Microsoft Windows 2000.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbbug kbClient kbConfig kbfix kbinterop kbInventory kbsmsAdmin kbWBEM KB279873