Cannot View smtppickupqueue from Computer Management on Mobile Information Server (279845)
The information in this article applies to:
- Microsoft Mobile Information 2001 Server
This article was previously published under Q279845 SYMPTOMS
When you attempt to view the smtppickupqueue Microsoft Message Queuing Service (MSMQ) queue from the Computer Management Microsoft Management Console (MMC) snap-in a Microsoft Mobile Information Server (MIS) computer, you receive the following error message:
Cannot read messages
Error: Access is denied.
CAUSE
This behavior is caused by improper permissions set for viewing the contents of the queue.
WORKAROUND
To view messages in the smtppickupqueue queue:
- Log on to the MIS server as a user with Local Administrator rights.
- Click Start, point to Programs, point to Administrative Tools, and then click Computer Management.
- Expand Services and Applications.
- Expand Message Queuing.
- Expand Private Queues.
- Right-click smtppickupqueue, and then click Properties.
- Click the Security tab, and then click Advanced.
- Click the Owner tab.
NOTE: Current owner of this item should read SYSTEM. - From the Change owner to list, click the account that you are currently logged on as (or the local administrator that you want to make the owner of the object account), and then click OK.
- Click Add, and then click the Microsoft Mobility Admins group from the Select Users, Computers, or Groups dialog box.
- In the Permissions list, click Allow next to Full Control, and then click OK.
NOTE: Be sure that the account that you attempt to view the queues with is a member of the Microsoft Mobility Admins group. - Attempt to view the smtppickupqueue queue. Any messages now in the queue will appear.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
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Keywords: | kbbug kberrmsg KB279845 |
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