MechWarrior 4 Error Message: Invalid to Call ApplyFilters When No Game List Has Been Created (279620)
The information in this article applies to:
- Microsoft MechWarrior 4: Vengeance
This article was previously published under Q279620 SYMPTOMS
When you attempt to connect to Zone.com from Microsoft MechWarrior 4: Vengeance, the ZoneMatch button may be unavailable, or you may receive one of the following error messages when you click ZoneMatch:
CAUSE
This behavior can occur if one of the following conditions is true:
- The Znmatch.dll and Zonenet.dll files are not registered properly
on your computer.
- The TCP/IP network protocol is not installed on your computer.
RESOLUTION
To resolve this issue, use the appropriate method for the error message that you received.
STOP: Invalid to Call ApplyFilters When No Game List Has Been Created
To resolve this issue, manually register the Znmatch.dll and Zonenet.dll files:
- Click Start, and then click Run.
- In the Open box, type the following line (including the
quotation marks), and then click OK
regsvr32 "drive:\program files\microsoft
games\mechwarrior vengeance\znmatch.dll"
where drive is the drive letter of the hard disk
on which MechWarrior 4 is installed.
- When you receive the message stating that the Znmatch.dll file was
registered successfully, click OK.
- Click Start, and then click Run.
- In the Open box, type the following line (including the
quotation marks), and then click OK
regsvr32 "drive:\program files\microsoft
games\mechwarrior vengeance\zonenet.dll"
where drive is the drive letter of the hard disk
on which MechWarrior 4 is installed.
- When you receive the message stating that the Zonenet.dll file was
registered successfully, click OK.
TCP/IP May Not Be Enabled
To resolve this issue, install the TCP/IP network protocol:
- Click Start, point to Settings, and then click
Control Panel.
- Double-click Network.
- On the Configuration tab, click Add.
- In the Click the type of network component you
want to install box, click Protocol, and then click
Add.
- In the Manufacturers box, click Microsoft.
- In the Network Protocols box, click TCP/IP.
- Click OK, and then click OK again.
- When you are prompted to restart the computer, click Yes.
Modification Type: | Minor | Last Reviewed: | 12/5/2002 |
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Keywords: | kberrmsg kbnetwork kbprb KB279620 |
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