XFOR: Groupwise Connector Logs Event 31000 and Mail Flow Stops (279261)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange Server 5.5

This article was previously published under Q279261

SYMPTOMS

In the Microsoft Exchange Connector for Novell GroupWise, the following symptoms may occur:
  • The Exchange GroupWise connector logs event 31000:
    Event Type: Error
    Event Source: MSExchangeGWISE
    Event Category: GroupWise to Exchange Conversion
    Event ID: 31000
    Date: 11/8/2000
    Time: 11:46:07 AM
    User: N/A
    Computer: EXCHANGESERVER
    Description:
    Resource error: File Name [{System failure}]
  • The mail flow from GroupWise to Exchange stops, but mail continues to flow from Exchange to GroupWise.
  • Files build up in the following directories:

    Exchsrvr\connect\gwrouter\gw2mex
    Exchsrvr\connect\gwrouter\gw2mexa

  • In the Exchange Connectivity logs, an error message similar to the following is logged:
    LME-GWISE-GW2MEX(03e4) 2 00018:Error {The filename was invalid} - Could not open the file C:\EXCHSRVR\Connect\Exchconn\gwrouter\gw2mexa\3a0911c7.BDY

CAUSE

This behavior occurs when a header file in the Exchsrvr\connect\gwrouter\gw2mex directory references an attachment within the same directory that you have either deleted or moved.

Here is a sample scenario that could lead to this behavior:
  • A GroupWise user sends a message to an Exchange user that contains a PowerPoint Presentation.
  • The Exchange GroupWise connector moves the message and attachment from the GroupWise server to the Exchange server.
  • A virus scanner that is running on the Exchange server finds a virus in the attachment file in the Exchsrvr\connect\gw2mexa directory, and deletes or renames it.
  • The Exchange GroupWise connector stops functioning correctly.

RESOLUTION

To resolve this behavior:
  1. Address the source of the problem: Disable or exclude the Exchsrvr directories from any virus scanning.
  2. Delete the problem message (or messages): Open your Connectivity logs from the Exchsrvr\CONNECT\Exchconn\logs directory, and find the entry that is similar to the one in the "Symptoms" section of this article. Make a note of the file name (in this case it would be 3a0911c7.bdy).
  3. Search for files in the Exchsrvr\exchconn\gwrouter\ directory that contain the text of the file name that you noted, which is the header file that is referencing the missing attachment file. Move or delete this file.

    NOTE: you may have to repeat this process several times, depending on how many problem messages you have.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbprb KB279261