OLEXP: Error Message "Msimn Caused a Stack Fault in Module Wsock32.dll" (279084)



The information in this article applies to:

  • Microsoft Outlook Express 5.5 for Windows Millennium Edition
  • Microsoft Outlook Express 5.5 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.01 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.0 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.5 for Windows 98
  • Microsoft Outlook Express 5.01 for Windows 98
  • Microsoft Outlook Express 5.0 for Windows 98
  • Microsoft Outlook Express 5.5 for Windows 95
  • Microsoft Outlook Express 5.01 for Windows 95
  • Microsoft Outlook Express 5.0 for Windows 95

This article was previously published under Q279084
For information about the differences between Microsoft Outlook Express and Microsoft Outlook e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base:

257824 OL2000: Differences Between Outlook and Outlook Express

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Outlook Express, you may receive the following error message:
Msimn caused a stack fault in module Wsock32.dll.

CAUSE

This behavior can occur if the W95.mtx virus program has infected your computer.

RESOLUTION

To remove the files that are infected by the W95.mtx virus program, edit the registry to remove the W95.mtx-related entries, rename the infected files that the virus installed on your hard disk, and then replace the Windows files that were infected by W95.mtx. To do this, follow these steps:

Removing the Registry Entries

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and click the following registry key:

    HKEY_LOCAL_MACHINE\Software\[Matrix]

  3. Right-click [Matrix], and then click Delete.
  4. Locate and click the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run\SystemBackup

  5. Right-click SystemBackup, and then click Delete.
  6. On the Edit menu, click Find.
  7. In the Find what box, type Mtx_.exe, and then click Find Next.
  8. If you find any copies of Mtx_.exe, delete them.
  9. Press F3 to search again. Delete any entries that are found.
  10. Repeat steps six to nine, but type [Matrix] in the Find what box.
  11. On the Registry menu, click Exit.

Locating Infected Files

  1. Click Start, point to Search, and then click Files and Folders.
  2. In the Named box, type Mtx_.exe.
  3. Set the Look In box to include your local hard disks, and then click Find Now.
  4. Copy the name of the folder where Mtx_.exe is located.
  5. Right-click Mtx_.exe, and then click Properties.
  6. If Read-only or Hidden is checked, click to remove the check.
  7. Click OK.
  8. Repeat steps 2 to 7, but type IE_pack.exe in the Named box.
  9. Repeat steps 2 to 7, but type Win32.dll in the Named box.
  10. Close the Find window.

Renaming Infected Files

  1. Click Start, and then click Shut Down.
  2. Click Restart in MS-DOS mode, and then click OK.
  3. Rename the following files by changing their extensions to ".old":
    • Mtx_.exe
    • IE_pack.exe
    • Win32.dll
    • C:\Windows\Explorer.exe
    • C:\Windows\Rundll32.exe
    • C:\Windows\System\Wsock32.dll

Replacing the Windows Files Infected by W95.mtx

  1. Extract new copies of Explorer.exe, Rundll32.exe and Wsock32.dll from the Windows cabinet files. For additional information about extracting files, click the article number below to view the article in the Microsoft Knowledge Base:

    129605 How to Extract Original Compressed Windows Files

  2. Restart Windows.
NOTE: Microsoft does not provide software that can detect or remove computer viruses. If you suspect or confirm that your computer is infected with a virus, obtain current antivirus software. For a list of antivirus software manufacturers, refer to the following article in the Microsoft Knowledge Base:

49500 List of Antivirus Software Vendors


Modification Type:MinorLast Reviewed:8/15/2005
Keywords:kberrmsg kbprb KB279084