Error Message "Error 1053" When Using the Services Snap-in (278712)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q278712

SYMPTOMS

When you use the Services snap-in to start a local service on a Microsoft Windows 2000-based computer, a Progress dialog box is displayed. If the service does not start in the three-minute time period set for this Progress dialog box, the snap-in may cause your system to display the following error message:
Error 1053: The service did not respond to the start or control request in a timely fashion.

CAUSE

This behavior may occur because the error message is displayed when the service takes more than three minutes to respond. This arbitrary time limit had been set with the intention that the user or administrator should be advised of the service status when this time limit is reached. However, the wording of the message may give the impression to the user that the service is unable to start, when in fact the service may simply be taking a very long time to start.

The preceding error message is misleading because the service may still be in a Start Pending state.

RESOLUTION

To work around this behavior, you must clear the error message and continue to check for the service to start. If the service does not start, you must check the System event log for Service Control Manager errors related to the service that is being monitored. If no error is posted to the event log, the service should eventually start.

For more information about troubleshooting Service Control Manager errors, please refer to the Microsoft Knowledge Base.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kberrmsg kbprb KB278712