XADM: Users Are Connected to Empty Mailboxes After a Failed Upgrade (278447)
The information in this article applies to:
- Microsoft Exchange 2000 Server
- Microsoft Exchange Server 5.5 SP3
This article was previously published under Q278447 SYMPTOMS
After you upgrade Exchange Server 5.5 Service Pack 3 (SP3) to Exchange 2000 Server, the original real mailboxes may be disconnected in the mailbox store in Exchange System Manager (a red x symbol is displayed next to the mailbox), and an empty mailbox may be connected to every user. Every user now has two mailboxes, a new blank mailbox and the original mailbox with the user's data.
CAUSE
This issue can occur if the mailbox store is unable to talk to Active Directory during the the upgrade. The store has to read the objectGuid attribute, copy it, and then put that same value into the msExchMailboxGUID attribute. When the mailbox store cannot talk to Active Directory, it generates a random msExchMailboxGUID attribute, which creates a new, blank mailbox for the user, and disconnects the user from the original mailbox.
RESOLUTION
To resolve this issue:
- Start the Services snap-in, and then quit the Microsoft Exchange message transfer agent (MTA) stacks and the Simple Mail Transfer Protocol (SMTP) services to prevent new mail from building up in the blank mailboxes.
- Use the ExMerge 2000 utility against the new mailboxes to retrieve mail.
- Start the Active Directory Users and Computers snap-in, right-click the user, click Exchange Tasks, and then click Delete.
- Start Exchange System Manager, right-click the Mailboxes object under the mailbox store, and then click Run Cleanup Agent.
- In Exchange System Manager, right-click the mailbox that had been disconnected, click Reconnect, and then click the user to which the mailbox belongs.
You can also automate this process by using the MBConn utility that is located in the Support\Utils\I386 folder on the Exchange Server CD-ROM. - Use ExMerge 2000 to import mail to the original mailbox, if necessary.
NOTE: After the upgrade, you may see a disconnected MS Mail Schedule + Free/Busy mailbox. You can delete this mailbox if you are not using MS Mail; this mailbox is a legacy mailbox that is left over from the upgrade. The default Recipient Update Policy may also have legacy MS Mail and Ccmail addresses which you can remove if you do not need them.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
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Keywords: | kbprb KB278447 |
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