SYMPTOMS
Post Office Protocol version 3 (POP3), Simple Mail Transfer Protocol (SMTP), or Internet Message Access Protocol Version 4rev1 (IMAP4) virtual servers may not start on a cluster server computer, and the following error messages may be logged:
Event Type: Error
Event Source: MSExchangeCluster
Event Category: Services
Event ID: 2086
Description:
%1 : Failed to set the start bit in the metabase in order to start the protocol, check if any process in the system is dead
For more information, click http://search.support.microsoft.com/search/?adv=1.
Event Type: Error
Event Source: MSExchangeCluster
Event Category: Services
Event ID: 2065
Description:
%1: Failed to bring the resource online
CAUSE
This issue can occur because the following setting in the metabase indicates to the Internet Information Service (IIS) that the corresponding service is cluster enabled:
If this setting is set to 0 (data==0) and the service is on a cluster, the error messages in the "Symptoms" section of this article are logged.
RESOLUTION
To resolve this issue, use MetaEdit to change the "Id: ClusterEnabled" setting on the cluster nodes that this issue occurs on.
WARNING: Using MetaEdit or Mdutil incorrectly can cause serious problems that may require reinstallation of IIS or your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of MetaEdit or Mdutil can be solved. Use these utilities at your own risk.
For information about how to edit the metabase, view the various Help topics in MetaEdit. Note that the metabase should be backed up by using the IIS Microsoft Management Console (MMC) snap-in before you edit the metabase.
Downloading MetaEdit
The following file is available for download from the Microsoft Download Center:
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.
Changing the "Id: ClusterEnabled" Setting
NOTE: The following procedure describes what to do if the SMTP virtual server does not start. If this issue occurs with another virtual server service, substitute the that service for SMTP in the following steps.
To change the "Id: ClusterEnabled" setting:
- Start MetaEdit on the first node.
- Click to expand LM.
- Click to expand SmtpSvc.
- Under SmtpSvc, numbers are displayed (1,2,3, and so on). These numbers correspond to the SMTP virtual servers that are present on the server. By default there is only one.
If you are unsure which number represents the virtual server that this issue occurred on, click a number (for example, 1, 2, or 3). In the right pane, a ServerComment box is displayed that contains the name of that SMTP server in Exchange System Manager. - Click the virtual server that this issue occurred on, and then click ClusteredEnabled.
- Right-click ClusteredEnabled, and then click Modify.
- If this virtual server is in a cluster, the data value should be 1. If this virtual server is not in a cluster, the data value should be 0.
- Perform the preceding steps on the other nodes in the cluster.