Unable to Preview Digital Video with Some Third-Party Digital Video Drivers (277813)
The information in this article applies to:
- Microsoft Windows Millennium Edition
- Microsoft Windows 98 Second Edition
This article was previously published under Q277813 SYMPTOMS
When you use a third-party digital video camera driver, you may be unable to preview video images. Note that this problem may occur on computers that are running Windows Millennium Edition (Me), or on computers that are running Windows 98 Second Edition and have installed the hotfix that is documented in the following Microsoft Knowledge Base article: 243174 Microsoft Digital Video May Lose IEEE 1394 Device Audio
CAUSE
This problem can occur if all of the following conditions exist:
- The software that is being used to display the video preview image uses the "Smart Tee" DirectShow filter.
- The digital video camera driver reports a video sample buffer size that is different from the actual data size.
RESOLUTION
To work around this problem, developers of digital video camera drivers can set the buffer size (m_cbBuffer) to the same size as the actual length (m_lActual) of the sample, and verify that both of these values are set to the correct value for the video format (NTSC or PAL) that is being used.
STATUSMicrosoft has confirmed that this is a problem in Windows Millennium Edition.
Microsoft has confirmed that this is a problem in Windows 98 Second Edition that includes the hotfix from Microsoft Knowledge Base article Q243174.
Modification Type: | Minor | Last Reviewed: | 9/28/2004 |
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Keywords: | kbenv kbnofix kbprb KB277813 |
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