Servers do not refresh NetBIOS name registrations with WINS (277695)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

This article was previously published under Q277695

SYMPTOMS

A server may not refresh NetBIOS name registrations with the server's configured WINS server. Eventually, the name registration tombstones, and then the name registrations are removed from the database of the WINS server.

CAUSE

This behavior occurs if you install the WINS service on a server because WINS refreshes only the server names locally and not with the configured WINS server in Transmission Control Protocol/Internet Protocol (TCP/IP) properties. When you reboot the server, the server's NetBIOS names are initially registered with the configured WINS server, but the server only refreshes names locally thereafter.

RESOLUTION

To resolve this behavior, either uninstall or disable the WINS service. To disable the WINS service, use the method for your operating system.

In Microsoft Windows NT 4.0

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Services.
  3. Click Windows Internet Name Service, and then click Stop.
  4. Click Yes at the prompt.
  5. Click Startup, and then click Disabled in the "Startup Type" section.
  6. Click OK, and then click Close.

In Microsoft Windows 2000

  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. Right-click Windows Internet Name Service, and then click Properties.
  3. In Startup type box, click Disabled.
  4. Click Stop in the "Service status" section.
  5. Click OK, and then close the Services dialog box.

In Microsoft Windows Server 2003

  1. Click Start, point to Administrative Tools, and then click Services.
  2. Right-click Windows Internet Name Service, and then click Properties.
  3. In Startup type box, click Disabled.
  4. Click Stop in the "Service status" section.
  5. Click OK, and then close the Services dialog box.

STATUS

This behavior is by design.

MORE INFORMATION

For additional information about this problem, click the article number below to view the article in the Microsoft Knowledge Base:

185786 Recommended Practices for WINS


Modification Type:MajorLast Reviewed:1/10/2005
Keywords:kbenv kbprb kbStack KB277695