Error Message: CFileException 2 Encountered While Attempting to Open %SystemRoot%:\SmallBusiness\... (277534)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.5
This article was previously published under Q277534 SYMPTOMS
When you run the Setup Computer Wizard, you may receive one of the following error messages:
"CFileException 2 encountered while attempting to open %SystemRoot%:\SmallBusiness\Template\arcnt386.inf"
"CFileException 2 encountered while attempting to open C:\SmallBusiness\Template\arc95.inf"
If you then click OK, Setup finishes. However, when you run the client disk on the client computer, the batch (.bat) file generates similar error messages, and although it runs, the client programs do not install. NOTE: The file that is referred to in the error message that you receive depends on the operating system that was specified for the client computer:
- Arcnt.inf - Microsoft Windows NT Workstation
- Arc95.inf - Microsoft Windows 95 or Microsoft Windows 98
CAUSE
This issue can occur because some versions of the Computer
Associates ARCServeIT program enter information into the Scw.ini and Clioc.inf files to provide the option to install "ARCServeIT Client Agent for Windows" during the client Setup process. However, note that ARCServeIT Client Agent for Windows should be installed locally at each client workstation, not from the server. The changes that are made to these two files cause the Setup Computer Wizard to search for the Arcnt386.inf and Arc95.inf files, but these files do not exist.
RESOLUTION
To work around this issue:
- Using a standard text editor (such as Notepad), edit the
Scw.ini file that is located in the
%SystemRoot%\SmallBusiness folder.
- Locate the SCW_NumberOfApps= line, and then subtract 2 from the number at the end of this line. For example, if the line has a 9 at the end of it (SCW_NumberOfApps=9), change the 9 to a 7 (SCW_NumberOfApps=7).
- Delete the following lines:
SCW_AppName7=ARCSERVE_NTAGENT_386
SCW_AppDisplayString7=ARCserveIT Client Agent for Windows NT
SCW_AppSelectedByDefault7=NO
SCW_AppRequiresUnattendedTextFile7=YES
SCW_AppTemplatePath7=
SCW_AppTemplateSourceName7=
SCW_AppTemplateDestName7=
SCW_AppSetupInfPath7=Template
SCW_AppSetupInfSourceName7=arcnt386.inf
SCW_AppSetupInfDestName7=arcnt386.inf
SCW_AppArchitectureList7=i386
SCW_AppName8=ARCSERVE_W95AGENT_386
SCW_AppDisplayString8=ARCserveIT Client Agent for Windows 95
SCW_AppSelectedByDefault8=NO
SCW_AppRequiresUnattendedTextFile8=YES
SCW_AppTemplatePath8=
SCW_AppTemplateSourceName8=
SCW_AppTemplateDestName8=
SCW_AppSetupInfPath8=Template
SCW_AppSetupInfSourceName8=arc95386.inf
SCW_AppSetupInfDestName8=arc95386.inf
SCW_AppArchitectureList8=win95
- Save the file, and then quit Notepad.
- Using a standard text editor (such as Notepad), edit the
Clioc.inf file that is located in the %SystemRoot%\SmallBusiness\Template folder.
- Delete the following lines:
arc95386="","",arc95386.inf
arcnt386="","",arcnt386.inf
[arc95386]
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ARCserveIT Client Agent for Windows 5","DisplayName"
[arcnt386]
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ARCserveIT Client Agent for Windows NT","DisplayName"
- Save the file, and then quit Notepad.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
Modification Type: | Major | Last Reviewed: | 7/26/2002 |
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Keywords: | kb3rdparty kbenv kberrmsg kbprb KB277534 |
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