Error "Page Cannot Be Displayed" After User's Catalog Set Is Deleted in Commerce Server (277359)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q277359

SYMPTOMS

When a registered user attempts to access a Commerce Seraver site, the user may receive the following error in the browser:

SiteName

The page cannot be displayed.

We apologize for the inconvenience. Please try again later. If the problem persists, please contact our webmaster.
where "SiteName" is the name of your Commerce site.

For a Retail2002 (Microsoft .NET) based site, you may receive the following error message:
Server Error in '/retail2002' Application.
----------------------------------------------------

The defaultAuthenticated catalogset ('Registered User Default CatalogSet') as specified in the CommerceServer\catalog\catalogSets section of web.config does not exist.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Microsoft.CommerceServer.Runtime.CommerceException: The defaultAuthenticated catalogset ('Registered User Default CatalogSet') as specified in the CommerceServer\catalog\catalogSets section of web.config does not exist.

CAUSE

This error can occur when you delete the default catalog set that is assigned to the user. When the catalog set is deleted, the u_user_catalog_set field in the UserObject table of the Commerce Server database still exists for the user's record that is assigned to that particular catalog set.

RESOLUTION

To allow the user to log on to the site, the site administrator must select a new default catalog set for the user in the user properties.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

You can assign catalog sets for individual users. After a user is assigned a catalog set, the user can browse catalogs in that set. This error may not manifest for some time after the catalog set is deleted. This is because the catalog information in cached in IIS and is not updated until either you run the IISRESET command or restart the store application. If you do not restart the application or run IISRESET, the user still has access to the catalog set even though it has been deleted from BizDesk.

Steps to Reproduce Behavior

  1. In BizDesk, from the Catalogs module, create a new catalog set.
  2. From the Users module, create a new user. In the Account Info section, under User Catalog Set, select the catalog set from step 1.
  3. Browse to the site as the new user.
  4. In BizDesk, delete the catalog set that you created in step 1.
  5. On the Start menu, click Run. At a command prompt, type the following command:

    IISRESET

  6. Browse to the site again as the new user. You receive the above-mentioned error message.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbpending kbprb KB277359